it-swarm.com.de

colord-sane Absturz nach dem Booten beim Start auf Xubuntu 16.04 64-Bit

Ich erhalte eine Popup-Meldung, die besagt, dass colord-sane abgestürzt ist, und ob ich einen Absturzbericht senden möchte. Ich bin sicher, dass es eine Protokolldatei dafür geben muss, aber ich weiß nicht, wo ich danach suchen soll, um es hier zu posten. In der Nachricht habe ich etwas über einige ppa-Repositories gelesen, die nicht auf dem neuesten Stand sind, was ich für absurd halte. Ich habe ein Sudo apt-get update im Terminal ohne Änderung durchgeführt. Der PC scheint so gut zu funktionieren, wie er ist, und alle Softwareprogramme scheinen auch so gut zu funktionieren. Ich bin mir nicht sicher, was das ist - ein Bug oder was. Weiß jemand, wie ich das Protokoll dieses Fehlers für weitere Hilfe posten kann?

Folgendes habe ich in /var/log/apport.log.1

ERROR: apport (pid 1368) Tue Jan 24 17:45:22 2017: called for pid 1091, signal 6, core limit 0
ERROR: apport (pid 1368) Tue Jan 24 17:45:22 2017: executable: /usr/lib/colord/colord-sane (command line "/usr/lib/colord/colord-sane")
ERROR: apport (pid 1368) Tue Jan 24 17:45:23 2017: is_closing_session(): no DBUS_SESSION_BUS_ADDRESS in environment
ERROR: apport (pid 1368) Tue Jan 24 17:45:24 2017: wrote report /var/crash/_usr_lib_colord_colord-sane.112.crash

Hier geht es darum, eine Lösung für den Fehler zu finden, der beim Absturz von colord-sane auftritt. Ich brauche jemanden, der mich durch die Stufen führt: 1, 2, 3, ... usw. Vielen Dank für Ihre Hilfe.

4
hienz1

Ich konnte es nicht beheben, indem ich sane-utils und colord deinstallierte.

sane-backends release 1.0.25+git20150528-1ubuntu4 behebt diesen Fehler wie gezeigt hier :

  * debian/patches/Kodak_avahi_crash.patch:
    - Fix crash when Avahi fails scanning for Kodak scanners

Um das Problem zu beheben, musste ich diese sane-backends Version herunterladen und installieren:

wget https://launchpad.net/ubuntu/+archive/primary/+files/sane-backends_1.0.25+git20150528.orig.tar.gz -O sane.tar.gz
tar -xf sane.tar.gz
cd sane-backends-git20150528
./configure
make
Sudo make install

Schließlich neu starten. Ich hoffe, es funktioniert für Sie.

2
mescarra

Sudo apt-get remove sane-utils Sudo apt-get remove colord

Arbeitete für mich, 16.04 mit XFCE, aber ich brauche keine Farbprofile.

0
B00MER