it-swarm.com.de

Wenn Sie versuchen, Qt unter OS X zu installieren, erhalten Sie "Sie müssen Xcode 5.0.0 installieren". Diese Version ist jedoch so alt, dass sie nicht verfügbar ist

Ich bin ein Windows/Linux-Entwickler, der gelegentlich für OS X entwickelt - insbesondere in Qt.

Ich habe ein einfaches Qt-Projekt, das ich unter Windows entwickelt habe. Ich möchte es jetzt auf OS X bauen.

Ich leite Yosemite. Ich habe Xcode 7 installiert und versuche, Qt 5.5 zu installieren.

Wenn ich das Qt-Installationsprogramm ausführen, unmittelbar nach der Aufforderung zur Anmeldung bei Qt (was erfolgreich ist), erhalte ich die folgende Fehlermeldung:

Sie müssen Xcode Version 5.0.0 installieren.

Qt installation fails

Ich habe versucht, Xcode 5.0.0 auf der Apple Developer Site zu finden, aber dies ist zwei Hauptversionen hinter der neuesten Version, und ich kann nicht einmal ein Installationsprogramm dafür finden.

Ich frage mich, warum die neueste Version von Qt eine Xcode-Version erfordert, die von Apple als so alt angesehen wird, dass sie nicht einmal verfügbar ist.

Wie kann ich dieses Problem überwinden, damit Qt unter OS X installiert werden kann?

34
Dan Nissenbaum

Ich bin auf das gleiche Problem gestoßen und habe es gelöst, indem ich die Anweisungen hier befolgt habe. Dieser Link beschreibt ein ähnliches, jedoch etwas anderes Installationsproblem.

Zusammenfassend müssen Sie sicherstellen, dass die Xcode-Befehlszeilentools ordnungsgemäß installiert und eingerichtet sind. Ich hatte sie bereits installiert, musste aber in Preferences -> Locations in Xcode gehen und die Dropdown-Liste auf die aktuell installierte Version setzen.

Der Link zeigt eine frühere Version von Xcode, bei der der Pfad tatsächlich Preferences -> Downloads -> Components ist.

Nach dieser Änderung wurde das Installationsprogramm erfolgreich fortgesetzt.

65
gus

Die Lösung, die für mich (unter OSX Sierra XCode 8.2.1) funktioniert hat, ist das Öffnen von XCode Preferences -> Locations.

Es gibt ein Dropdown-Menü mit dem Namen Command Line Tools. Wählen Sie hier die verfügbare XCode-Version aus. Starten Sie anschließend die Installation von qt Creator erneut.

19
Francesco Boi

aus dem obigen Link genommen, wurde mein Problem gelöst:

Sudo /usr/bin/xcode-select -switch /Applications/Xcode.app/Contents/Developer 
12
TSga

Für mich das Schließen der Prompt- und Smashing-Tasten (alt F4, ich weiß, dass es keine Fenster ist), bevor die nächste Eingabeaufforderung geöffnet wurde, funktionierte das ... qt läuft jetzt einwandfrei, da die alte Version nicht benötigt wird.

0
user11074957