it-swarm.com.de

Ich bekomme die PHP Die Datums-/Uhrzeitbibliothek wird von Ihrem Webhost nicht unterstützt. "Welche Bibliothek muss ich auf meinem CentOS-Host installieren, um Unterstützung hinzuzufügen?

Ich habe mich schnell umgesehen, aber meine PHP Fähigkeiten sind ziemlich aufkeimend. Ich bin sicher, dass es nur ein Paket gibt, das installiert werden muss.

Bearbeiten, um zusätzliche Informationen zum Setup hinzuzufügen:

Verwenden von:

yum info php

Ich bekomme die Version von PHP als 5.1.6:

Name       : php
Arch       : i386
Version    : 5.1.6

Weitere Informationen, dies ist ein VM, auf dem CentOS bei GoDaddy ausgeführt wird:

CentOS release 5.4 (Final)
1
Larry Smithmier

Aktualisieren Sie auf PHP 5.2 oder höher

Die Fehlermeldung, die Sie sehen, ist von WordPress. Es ist sehr irreführend, dass Sie eine PHP Version> = 5.2 benötigen, damit diese Funktion funktioniert.

Lesen Sie in der Dokumentation Ihres Betriebssystems nach oder wenden Sie sich an den technischen Support, um zu erfahren, wie Sie Ihre PHP -Version aktualisieren können. Für CentOS zum Beispiel: CentOS HowTos: PHP 5.1 bis 5.2

Aktualisierte Zeitzonen beibehalten

Um die Unterstützung von PHP Timezone optimal zu nutzen , gibt es ein PECL-Paket mit den neuesten Updates: timezonedb .

Neben dem Upgrade von PHP auf eine neuere Version können Sie dieses PECL-Paket installieren und auf dem neuesten Stand halten, um die neuesten Zeitzonenupdates zu erhalten (das letzte war am 16. August):

$ yum install php-pear php-devel
$ pecl install timezonedb
3
hakre

wp-admin/options-general.php gibt die folgende Fehlermeldung aus:

Leider müssen Sie dies für die Sommerzeit manuell aktualisieren. Die PHP Date/Time-Bibliothek wird von Ihrem Webhost nicht unterstützt.

Dieser Codeblock wird ausgegeben, wenn die folgenden von PHP bereitgestellten Funktionen fehlen:

Viele dieser Funktionen werden von der DateTime Klassenfamilie bereitgestellt. Diese sind je nach Funktion seit Version 5.1/5.2 Bestandteil von PHP core. Obwohl ich es hasse, in einer Antwort um Klärung zu bitten: Welche Version von PHP wird auf Ihrem Host ausgeführt?

1

Smithmier **:

UPDATE: Ich sehe durch dein Update, dass dies nicht auf dich zutrifft, aber es würde auf viele andere mit demselben Problem zutreffen und wir suchen nach allgemeinen Antworten auf Fragen Das gilt für mehr als nur eine Person. Ich werde es verlassen.


Ich gehe davon aus, dass @hakre richtig ist und , wenn ja und , wenn Ihr Webhost CPanel anbietet, damit Sie die technischen Details Ihres Webhosting-Kontos verwalten können Dann können Sie hier Ihre PHP-Version ändern:

Screenshot for PHP Configuration on CPanel
(Quelle: mikeschinkel.com )

Von dort gelangen Sie zu diesem Bildschirm, auf dem Sie Ihre PHP-Version ändern können:

Changing your version of PHP on CPanel
(Quelle: mikeschinkel.com )

1
MikeSchinkel