it-swarm.com.de

Beim Versuch, eine selbst gehostete WordPress-Site zu aktualisieren, wird "ASN1 unknown message digest algorithm" angezeigt

Ich habe mehrere WordPress-Sites, die ich auf einem Windows-Server selbst hoste.

Beim Versuch, den Upgrade-Prozess über /wp-admin/update-core.php?action=do-core-upgrade auszuführen, wird der folgende Fehler angezeigt:

fehler: 0D0890A1: asn1-Codierungsroutinen: ASN1_verify: unbekannter Message Digest-Algorithmus

Mir ist völlig unklar, wo ich anfangen soll, dieses Problem zu lösen.

Interessanterweise zeigt das Applet "WordPress News" einen ähnlichen Fehler:

RSS-Fehler: WP HTTP-Fehler: Fehler beim Empfangen von Daten vom Peer

RSS-Fehler: WP HTTP-Fehler: Fehler: 0D0890A1: asn1-Codierungsroutinen: ASN1_verify: unbekannter Message Digest-Algorithmus

3
Max Vernon

@Kika hat recht, dass Sie eine ältere, unsichere Version von OpenSSL haben.

Dies klingt wie folgt: https://wordpress.org/support/topic/getting-download-failed-error0d0890a1asn1-encoding-routinesfunc137reason

Ich habe ein wenig Code geschrieben, um den SSL-Test zu überspringen, wenn ich versuche, auf den Download-Server zuzugreifen. Es ist keine gute Idee, diesen Code zu verwenden, aber er hilft Ihnen dabei.

<?php
/*
Plugin Name: Skip SSL Verify
Plugin URI: http://www.damiencarbery.com
Description: Skip SSL verify in curl downloads - fixes: Download failed. error:0D0890A1:asn1 encoding routines:func(137):reason(161).
Author: Damien Carbery
Version: 0.1
*/

function ssv_skip_ssl_verify($ssl_verify) {
    return false;
}
add_filter('https_ssl_verify', 'ssv_skip_ssl_verify');
add_filter('https_local_ssl_verify', 'ssv_skip_ssl_verify');
2
Damien Carbery