it-swarm.com.de

Wie kann man sich für Ralink 148f: 7601 entscheiden?

Ich habe gerade meinen neuen USB-WLAN-Dongle bekommen und versuche, ihn am 13.10. Zum Laufen zu bringen. lsusb gibt mir Folgendes:

$ lsusb -v 
Bus 002 Device 005: ID 148f:7601 Ralink Technology, Corp. 
  bDeviceSubClass         0 
  bDeviceProtocol         0 
  bMaxPacketSize0        64
  idVendor           0x148f Ralink Technology, Corp.
  idProduct          0x7601 
...

Als erstes habe ich versucht, die Treiber von der mitgelieferten CD zu installieren. Dort habe ich diese Datei gefunden 2011_0719_RT3070_RT8070_RT3370_RT5370_RT5372_RT2070_Linux_STA_V2.5.0.3_DPO.bz2 und in der Readme gab es einen Hinweis für

ModelName:
===========
RT2870 Wireless Lan Linux Driver

=======================================================================
Driver lName:
===========
rt2870.o/rt2870.ko

Nachdem ich Sudo make gestartet habe (Sudo, weil ich ein Problem beim Kopieren nach cp cannot create regular file /tftpboot' permission denied hatte), kann ich jetzt Sudo make install

$ Sudo modprobe rt5370sta

Ich habe auch rt2800usb, aber es funktioniert auch nicht.

Wenn ich jetzt den USB-Dongle betrete, erhalte ich syslog

Feb 18 15:53:03 xxx kernel: [  302.509247] usb 2-1.3: new high-speed USB device number 5 using ehci-pci
Feb 18 15:53:04 xxx kernel: [  302.969353] usb 2-1.3: New USB device found, idVendor=148f, idProduct=7601
Feb 18 15:53:04 xxx kernel: [  302.969359] usb 2-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Feb 18 15:53:04 xxx mtp-probe: checking bus 2, device 5: "/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.3"
Feb 18 15:53:04 xxx mtp-probe: bus: 2, device: 5 was not an MTP device

Ich habe es auch versucht http://gowthamgowtham.blogspot.com/2013/11/mediatekralink-wifi-adapter-in.html , aber wenn ich ra0 eingebe zu /etc/network/interfaces, dann bootet der PC nicht länger als 1-3 Minuten und beim Booten wird nur die lo Schnittstelle geladen.

EDIT

Das Beste daran ist, dass der größte Teil des Links auf der MediaTek-Website (sie hatten anscheinend eine Fusion) nicht vorhanden ist http://www.mediatek.com/_en/07_downloads/01_windows.php?sn=501

EDIT2

Nachdem ich irgendwie 3.0.0.4-Treiber für mt7601U in die Hände bekommen habe, erhalte ich in syslog Folgendes:

Feb 18 16:55:26 xxx kernel: [ 1975.959906] rtusb init rt2870 --->
Feb 18 16:55:26 xxx kernel: [ 1975.959913] Error: Driver 'rt2870' is already register
ed, aborting...

EDIT3

Ich habe das irgendwie zum Laufen gebracht, aber wenn ich wpa_supplicant starte, erhalte ich das folgende Debug-Protokoll

http://paste.ubuntu.com/6955249/

3
Patryk

Ich glaube diesen Fehler:

Fehler: Treiber 'rt2870' ist bereits registriert und bricht ab ...

schlägt vor, dass entweder rt5370sta oder rt2800usb bereits geladen ist; prüfen:

lsmod | grep -e rt5 -e rt2

Weder ist für Ihr Gerät richtig. Wenn eines von beiden gefunden wird, entladen Sie es:

Sudo modprobe -r <driver_you_found>

Wenn eines von beiden in/etc/modules aufgerufen wird, entfernen Sie es.

Gibt es noch andere interessante Hinweise?

Sudo modprobe mt7601Usta
dmesg | grep -e mt7 -r 2870
iwconfig
1
chili555

Laut lsusb habe ich das gleiche Gerät:

Bus 002 Device 018: ID 148f:7601 Ralink Technology, Corp. 

Die CD enthält die folgende Datei:

DPO_MT7601U_LinuxSTA_3.0.0.4_20130913.tar.bz2

Kann auch von der offiziellen Website heruntergeladen werden: http://www.mediatek.com/en/downloads/mt7610u-usb/

Extrahieren Sie die Datei, geben Sie das Verzeichnis ein, das das Makefile enthält, und führen Sie Folgendes aus:

$ make
$ Sudo make install

Nach diesen Schritten funktionierte das Gerät nahtlos. Viel Glück!

In den neuesten Versionen von Ubuntu (14.04) wird ein Patch benötigt. Dieser Link erklärt, was benötigt wird: https://unix.stackexchange.com/a/158032/97282

6
Aron