it-swarm.com.de

Ubuntu 14.04: Mein Computer erkennt das drahtlose Netzwerk, stellt jedoch keine Verbindung her und fragt immer wieder nach dem Kennwort WPA

Sony Vaio VGN-NW240F
Netzwerkcontroller: Qualcomm Atheros AR9285 Wireless-Netzwerkadapter (PCI-Express) (Version 01)

$ lspci -vv -s
Subsystem: Foxconn International, Inc. T77H126.00 802.11bgn Wireless Half-size Mini PCIe Card
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0, Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 17
Region 0: Memory at d2500000 (64-bit, non-prefetchable) [size=64K]
Capabilities: <access denied>
Kernel driver in use: ath9k

$ modinfo ath9k
filename:       /lib/modules/3.13.0-24-generic/kernel/drivers/net/wireless/ath/ath9k/ath9k.ko
license:        Dual BSD/GPL
description:    Support for Atheros 802.11n wireless LAN cards.
author:         Atheros Communications
srcversion:     BAF225EEB618908380B28DA
alias:          platform:qca955x_wmac
alias:          platform:ar934x_wmac
alias:          platform:ar933x_wmac
alias:          platform:ath9k
alias:          pci:v0000168Cd00000036sv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000036sv0000185Fsd00003027bc*sc*i*
[alias...]
depends:        ath9k_hw,mac80211,ath9k_common,cfg80211,ath
intree:         Y
vermagic:       3.13.0-24-generic SMP mod_unload modversions 
signer:         Magrathea: Glacier signing key
sig_key:        00:A5:A6:57:59:DE:47:4B:C5:C4:31:20:88:0C:1B:94:A5:39:F4:31
sig_hashalgo:   sha512
parm:           debug:Debugging mask (uint)
parm:           nohwcrypt:Disable hardware encryption (int)
parm:           blink:Enable LED blink on activity (int)
parm:           btcoex_enable:Enable wifi-BT coexistence (int)
parm:           bt_ant_diversity:Enable WLAN/BT RX antenna diversity (int)
parm:           ps_enable:Enable WLAN PowerSave (int)

Mein Netzwerk funktioniert perfekt mit diesem Computer unter Windows 7 und mit verschiedenen anderen Computern und Geräten. Ich habe heute Ubuntu 14.04 installiert und es funktioniert einwandfrei, mit Ausnahme des WiFi.

Wenn ich versuche, eine Verbindung herzustellen (WLAN-Symbol, Name_des_Netzwerks), wird ungefähr jede Minute ein Popup-Fenster angezeigt, in dem Sie nach dem Kennwort gefragt werden. Die Verbindung wird nicht hergestellt. Das Passwort ist korrekt.

Ich habe versucht, das Netzwerk aus der Verbindungsliste zu löschen (WLAN-Symbol, Verbindungen bearbeiten), meinen Computer neu zu starten und es erneut zu versuchen, ohne Erfolg.

Ethernet funktioniert einwandfrei.

Ich muss davon ausgehen, dass es sich um Ubuntu handelt, da die WLAN-Karte erkannt wird und die verschiedenen verfügbaren Netzwerke scannen kann.

$ rfkill list
0: sony-wifi: Wireless LAN
Soft blocked: no
Hard blocked: no
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

Ich kenne Ubuntu 14.04 nicht gut genug, um überhaupt etwas auszuprobieren.

Irgendwelche Vorschläge?

6
William Abma

Mein Problem wurde behoben. Ich bin mir nicht ganz sicher, wie, aber hier ist, was ich getan habe:

Sudo service network-manager restart

Vielleicht hilft das anderen, die dieses Problem haben, wenn das natürlich die Lösung wäre.

10
William Abma

Bitte entschuldigen Sie den Mangel an Formalität in dieser Antwort - nur eine kurze Mitteilung an andere für das einzige, was für mich nach Stunden des Suchens und Versuchens verschiedener Dinge funktioniert hat .

Ich habe ewig versucht, etwas zum Laufen zu bringen - am Ende stellte sich heraus, dass die Netzwerkkarte selbst funktionierte (weil es auf einem anderen Betriebssystem in Ordnung war). dass das WiFi-Netzwerk funktionierte (weil ich dort auf meinem Handy sitzen konnte, wenn ich es benutzte); dass das Passwort korrekt war; und dass ich über meine Kabelverbindung eine Verbindung zum Internet herstellen könnte.

Das Problem, das sich für mich herausstellte, war, dass die Netzwerkkarte, die ich habe, ein bisschen ... nicht so toll ist.

Zuerst habe ich hier herausgefunden was meine Netzwerkkarte war

Sudo lshw -class network

(Es handelt sich um einen Realtek RTL8821AE 802.11ac PCIe Wireless-Netzwerkadapter, daher habe ich bei meiner Suche "RTL8821AE" verwendet.)

Dann habe ich nach dem Treiber gesucht und es hat eine Weile gedauert, aber irgendwann habe ich diesen Thread gefunden, der besagt, dass es einen neuen gibt ... ich werde Fahrer sagen (?!) ... und bin dem gefolgt Anleitung. Nur über den Github-Link konnte ich herausfinden, wo sich der ... ich sage Treiber (?!) ... befand und auf meinen Laptop heruntergeladen, entpackt und auf einen USB-Stick kopiert hat. Dann habe ich einfach die make-Befehle usw. ausgeführt. Boom! es funktionierte :)

Und ich musste diesen Befehl auch manchmal verwenden, um einen Cache zu leeren oder was auch immer:

Sudo service network-manager restart
2
ja_him

Ich hatte das gleiche Problem, als ich mich in meinem Heimnetzwerk befand und zwischen einer kabelgebundenen und einer kabellosen Verbindung wechselte. Nachdem es ein paar Tage gut funktioniert hatte, funktionierte das Funkgerät plötzlich nicht mehr. Ich konnte das drahtlose Netzwerk sehen, aber beim Versuch, eine Verbindung herzustellen, wurde ständig nach einem Kennwort gefragt.

Ich habe das Problem behoben, indem ich den neuen Treiber für meine Netzwerkkarte installiert und den Router aus- und wieder eingeschaltet habe.

Ich hoffe das hilft jedem bei ähnlichen Problemen!

0
DVI

Wenn jemand das gleiche Problem wie ich hat, müssen Sie jedes Mal Sudo service network-manager restart ausführen, wenn Sie sich anmelden, damit Ihr WLAN funktioniert. Ich habe einen dauerhaften Fix für meinen Netzwerkadapter gefunden, der mit der neueren Version von Ubuntu nicht mehr funktioniert. Ignoriere meine vorherigen Kommentare zum Downgrade des Kernels, da das Hauptproblem das neue wpasupplicant-Paket in 14.04 war.

Meine Lösung bestand darin, dieses ppa zu bekommen: deb http://ppa.launchpad.net/mathieu-tl/nm/ubuntu saucy main es enthält Ubuntus 13.10 Network Manager-Paket und wpasupplicant-Paket. Ich ging zu Synaptic und stufte nur das wpasupplicant-Paket herunter. Ich muss den Befehl Sudo service network-manager restart nie wieder ausführen.

0
answerSeeker

Dies ist keine Lösung, sondern eine Problemumgehung. Sie können die Befehlszeilenschnittstelle nmcli für den Netzwerkmanager verwenden. Zum Beispiel:

nmcli d wifi connect <Your-SSID> password <Your-Password>

Lassen Sie mich wissen, ob Sie sich damit verbinden können.

0
Prathu Baronia