it-swarm.com.de

Sehr langsame, intermittierende WiFi-Geschwindigkeiten mit 14.04 und Intel PRO / Wireless 5100 AGN [Shiloh]

Ich habe eine Neuinstallation von Ubuntu 14.04 LTS auf der Festplatte eines Lenovo Y650 Ideapad-Laptops durchgeführt. Der drahtlose Adapter ist ein Intel PRO/Wireless 5100 AGN [Shiloh].

Anfangs konnte ich keine Verbindung zu drahtlosen Netzwerken herstellen. ich konnte sie jedoch sehen. Bei der Verbindung über Ethernet treten keine Probleme auf. Ich konnte mich nur mit dem folgenden Befehl im Terminal mit dem drahtlosen Netzwerk verbinden:

echo "options iwlwifi 11n_disable=1" | Sudo tee /etc/modprobe.d/iwlwifi.conf

Die Geschwindigkeiten sind extrem langsam und intermittierend. Wenn ich in der Lage bin, einen Geschwindigkeitstest durchzuführen, ist der Ping gut (24 bis 26 ms), aber die Download-Geschwindigkeiten reichen von 0,15 bis 0,30 Mbit/s.

iwconfig

eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11abg  ESSID:"PinkRabbit"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: E8:40:F2:CD:18:0B   
          Bit Rate=2 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=70/70  Signal level=-26 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:3  Invalid misc:254   Missed beacon:0

ifconfig

eth0      Link encap:Ethernet  HWaddr 00:23:5a:d2:70:91  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:17 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:171 errors:0 dropped:0 overruns:0 frame:0
          TX packets:171 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:15613 (15.6 KB)  TX bytes:15613 (15.6 KB)

wlan0     Link encap:Ethernet  HWaddr 00:1e:65:3e:0c:48  
          inet addr:192.168.0.13  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::21e:65ff:fe3e:c48/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:42 errors:0 dropped:0 overruns:0 frame:0
          TX packets:96 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:9032 (9.0 KB)  TX bytes:16851 (16.8 KB)

nm-tool

NetworkManager Tool

State: connected (global)

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            tg3
  State:             unavailable
  Default:           no
  HW Address:        00:23:5A:D2:70:91

Capabilities:
    Carrier Detect:  yes

Wired Properties
    Carrier:         off

- Device: wlan0  [PinkRabbit] --------------------------------------------------
  Type:              802.11 WiFi
  Driver:            iwlwifi
  State:             connected
  Default:           yes
  HW Address:        00:1E:65:3E:0C:48

  Capabilities:
    Speed:           1 Mb/s

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points (* = current AP)
    *PinkRabbit:     Infra, E8:40:F2:CD:18:0B, Freq 2412 MHz, Rate 54 Mb/s, Strength       92 WPA WPA2

  IPv4 Settings:
    Address:         192.168.0.13
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.0.1

    DNS:             64.71.255.204
    DNS:             64.71.255.198
    DNS:             8.8.8.8
    DNS:             8.8.4.4
10
user3232837

Ich weiß nicht, wie wichtig das ist, immer noch ein Ubuntu-Neuling, aber ich hatte ähnliche Probleme mit meiner Ralink 5362-Karte.

Das einzige, was es zu funktionieren schien, war das Folgende:

Es gibt einen Fehler im Debian Avahi-Daemon in Ubuntu. Um dies zu beheben, müssen Sie die folgende Datei /etc/nsswitch.conf wie folgt bearbeiten.

Geben Sie Folgendes in die Befehlszeile ein

Sudo -H gedit  /etc/nsswitch.conf

Dadurch wird die Datei nsswitch.conf im Texteditor geöffnet. Dann ändern Sie einfach die folgende Zeile

hosts:          files mdns4_minimal [NOTFOUND=return] dns mdns4

in die untere Zeile und speichern Sie die Datei.

hosts:          files dns

Setzen Sie Ihre Internetverbindung zurück oder starten Sie wahrscheinlich Ihr System neu und Ihre drahtlose Verbindung sollte wieder auf Höchstgeschwindigkeit sein. Das hat zumindest bei mir funktioniert.

11

Eigentlich habe ich auch dieses Problem, also freue ich mich auf eine dauerhafte Lösung, aber eine vorübergehende wäre:

Sudo iwconfig wlan0 rate 54M

wobei 54M Ihre tatsächliche Wireless-Fähigkeit ist.

4
k0ryfi

Ich habe das gleiche Problem bei meinem Laptop festgestellt (Intel Wireless 7260/Lenovo W540). Alle paar Tage verlangsamt sich das Netzwerk zu einem Crawl (einschließlich Datenverkehr über alle Protokolle: http, ssh, ftp usw.). Ich glaube, ich habe das gleiche Verhalten gegenüber eth0 erlebt, kann mich aber nicht erinnern.

Die Problemumgehung besteht für mich darin, den Netzwerk-Manager neu zu starten - das scheint alle Probleme zu beseitigen.

[email protected]:~$ Sudo service network-manager restart

lshw

[email protected]:~$ Sudo lshw -C network
  *-network               
       description: Ethernet interface
       product: Ethernet Connection I217-LM
       vendor: Intel Corporation
       physical id: 19
       bus info: [email protected]:00:19.0
       logical name: eth0
       version: 04
       serial: 3c:97:0e:ea:1b:a4
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=2.3.2-k firmware=0.13-3 latency=0 link=no multicast=yes port=twisted pair
       resources: irq:44 memory:b2a00000-b2a1ffff memory:b2a3f000-b2a3ffff ioport:5080(size=32)
  *-network
       description: Wireless interface
       product: Wireless 7260
       vendor: Intel Corporation
       physical id: 0
       bus info: [email protected]:03:00.0
       logical name: wlan0
       version: 6b
       serial: 7c:7a:91:06:7b:e2
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=3.13.0-29-generic firmware=22.1.7.0 ip=192.168.1.158 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:45 memory:b2800000-b2801fff
2
Justin

Ich kann Ihnen vorschlagen, den Kernel 3.13.0-37_3.13.0-37.64 + iwlltr0001 von folgender Adresse zu installieren: http://people.canonical.com/~sforshee/iwl-ltr/trusty/

und die Intel-Firmware iwlwifi-3160-9-ucode.

Danach habe ich ein Terminal eingegeben:

$echo "options iwlmvm power_scheme=1" | Sudo tee /etc/modprobe.d/iwlmvm.conf
$echo "options iwlwifi bt_coex_active=Y swcrypto=1 11n_disable=1" | Sudo tee /etc/modprobe.d/iwlwifi.conf
$Sudo reboot

1
ai20
  1. Öffnen Sie "Zusätzliche Treiber"
  2. Gehen Sie zur Registerkarte "Andere Software" und aktivieren Sie alle Kontrollkästchen
  3. Aktualisieren Sie den Treiber
1
imeckr