it-swarm.com.de

Qualcomm Atheros - Langsam / Keine Verbindung unter Ubuntu, funktioniert aber unter Win 10

Ich habe einen Qualcomm Atheros QCA6174-Netzwerktreiber.

Ich habe sehr langsames Wifi auf meinem Linux-Betriebssystem, aber es funktioniert einwandfrei unter Windows 10. Wenn ich ein Ethernet-Kabel verwende, funktioniert alles, aber WiFi ist langsam und stellt manchmal einfach keine Verbindung her.

Kann mich jemand anleiten, wie ich das beheben kann?

Hier sind einige weitere Informationen zu meinem Treiber:

Network controller [0280]: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter [168c:003e] (rev 20)

Subsystem: Foxconn International, Inc. QCA6174 802.11ac Wireless Network Adapter [105b:e08e]

Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+

Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx+

Latency: 0, Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 35
Region 0: Memory at d1400000 (64-bit, non-prefetchable) [size=2M]
Capabilities: <access denied>
Kernel driver in use: ath10k_pci
Kernel modules: ath10k_pci
3
VBoi

Alles klar, Sie könnten versuchen, Ihrer Konfiguration eine Zeile hinzuzufügen

Sudo su
echo "options ath9k nohwcrypt=1" >> /etc/modprobe.d/ath9k.conf

Starten Sie dann Ihren PC neu, um festzustellen, ob dies geholfen hat. Wenn dies Ihr Geschwindigkeitsproblem nicht behebt, habe ich einen anderen Trick, den Sie verwenden könnten.

Deaktivieren Sie das 802.11n-Protokoll. Während das Protokoll bei neueren Routern eine bessere Geschwindigkeit bieten soll. Die meisten modernen Router verwenden dieses Protokoll nicht, was zu Problemen führen kann.

Öffnen Sie das Terminal und verwenden Sie den folgenden Befehl:

Sudo rmmod iwlwif
Sudo modprobe iwlwifi 11n_disable=1

Versuchen Sie nun erneut, eine Verbindung zum Netz herzustellen, wenn dies das Problem nicht behebt. Wenn dies jedoch der Fall ist, werden diese Befehle permanent ausgegeben, um die Änderung zu bewirken.

Sudo su
echo "options iwlwifi 11n_disable=1" >> /etc/modprobe.d/iwlwifi.conf

Hoffentlich hat dies Ihr Problem behoben. Andernfalls können Sie IPv6 deaktivieren, obwohl ich nicht sicher bin, ob Ihr Provider IPv6 unterstützt. Manchmal kann dies dazu führen, dass bestimmte Router und ISPs testen, ob dies der Fall ist Problem

Sudo su
echo "#disable ipv6" >> /etc/sysctl.conf
echo "net.ipv6.conf.all.disable_ipv6 = 1" >> /etc/sysctl.conf
echo "net.ipv6.conf.default.disable_ipv6 = 1" >> /etc/sysctl.conf
echo "net.ipv6.conf.lo.disable_ipv6 = 1" >> /etc/sysctl.conf

Für eines der oben genannten nur Sudo gedit 'den Dateinamen und Speicherort' wie z

Sudo gedit /etc/modprobe.d/ath9k.conf

Dann feine die Linie, die hinzugefügt wurde und entfernen Sie es.

Die zweite Lösung, die ich bereitgestellt habe, war eine Möglichkeit, zu testen, ob sie hilfreich ist, bevor sie dauerhaft ist. Sie müssen also keine manuellen Änderungen vornehmen, um sie rückgängig zu machen, es sei denn, Sie wählen den Schritt aus, der die Änderung dauerhaft macht.

Wenn nichts, was ich zur Verfügung gestellt habe, geholfen hat, bitte Kommentar zurück zu mir usw.

1
Alex Cooper