it-swarm.com.de

Wie installiere (oder verspotte) ich den Internet Explorer?

Ich muss eine Windows-Anwendung installieren, die überprüft, ob Internet Explorer mit mindestens der fünften Version installiert ist, und die Installation ablehnt (obwohl ich glaube, dass dies nicht unbedingt erforderlich ist), wenn dies nicht der Fall ist.

Ich habe versucht, Winetricks zu installieren, dh 8, 7, 6 vollständige, 6 Versionen, die es anbietet - keine funktionierte - Installer der Versionen 7 und 8 melden eine in msvcr fehlende Funktion (die Installation aller msvcr-Versionen hat nicht geholfen), dh6 meldet einen anderen Fehler (Ich werde angeben, ob es darauf ankommt).

Ich habe auch IEs4Linux ausprobiert - es schlägt ebenfalls fehl und beklagt sich über einen von ies4linux-gtk.py empfangenen "BadIDChoice" X Window System-Fehler.

Gibt es eine Möglichkeit, eine IE -Version in Ubuntu 10.10 mit Wine zu installieren oder ihre Anwesenheit zu verspotten? Ich brauche es nicht einmal, um zu funktionieren, nur um im Wine-System installiert zu werden, damit andere Windows-Programme sehen können, dass es da ist.

Ich benutze Ubuntu 10.10 mit Wine 1.3.8.

6
Ivan

Wenn Sie es fälschen wollen, versuchen Sie: winetricks

alt text

Wenn dies nicht funktioniert, kann ich Ihnen nicht viel helfen, es sei denn, Sie schlagen vor, mit playonlinux zu installieren und dann Ihr Weinpräfix durch das Präfix des Benutzers zu ersetzen, aber das würde bedeuten, dass Sie alles neu installieren müssen.

6
RolandiXor

Die Antworten sind in meinem Blogpost . Da Sie bereits die Wine PPA mit den Beta-Weinen haben, sollten Sie bereits Winetricks haben. Buchstäblich alles, was Sie an diesem Punkt tun müssen, ist:

winetricks ie6

(oder Winetricks IE7 oder Winetricks IE8). Beachten Sie, dass ich nicht sicher bin, ob ie8 an diesem Punkt tatsächlich funktioniert, aber es wird zumindest installiert.

Wenn Sie einen gefälschten Internet Explorer möchten, ist dies jetzt eine integrierte Funktion von Wine, vorausgesetzt, Sie haben Wines Gecko installiert. Wine-Gecko ist in einem separaten Paket enthalten, sollte jedoch bei der Installation von Wine automatisch installiert werden.

3
Scott Ritchie

Ivan, in der Wine HQ AppDB (http://appdb.winehq.org) gibt es Einträge für mehrere Versionen von Internet Explorer. Hast du sie alle ohne Erfolg ausprobiert? Achten Sie auf die Versionen, es ist nicht ungewöhnlich, dass eine neuere Wine-Version Apps beschädigt, die in einer früheren Version funktionierten.

Da ich jedoch nie die Notwendigkeit hatte, IE unter Wine zu verwenden (und es nie ausprobiert habe), würde ich Ihnen aus Gründen der Einfachheit ausdrücklich empfehlen, PlayOnLinux zu verwenden, das Sie können

apt-get installiere playonlinux

Bisher hatte ich keine Probleme bei der Installation von Spielen und Apps über Skripte in deren Repositorys. Hier gibt es viele Möglichkeiten:

  • Verwenden Sie es direkt, um IE 6 oder 7 zu installieren
  • Verwenden Sie ihre Website, um zu überprüfen, was ihre Skripte tun, damit Sie es stattdessen selbst tun können (überprüfen Sie http://www.playonlinux.com/repository/?cat=4 und klicken Sie dann auf IE 6 & 7 Einträge)
  • Sie können es einfach verwenden, um eine "Wine-Umgebung" zu verwalten und verschiedene Wine-Präfixe/-Versionen für jede App zu konfigurieren - auch wenn kein Skript von ihnen verfügbar ist, aber Sie können die Anwendung selbst konfigurieren/ausführen

Wenn Sie Firefox verwenden, können Sie diese Erweiterung verwenden, um den Browser-Agenten zu verspotten.

Ich weiß, dass es irgendwie nicht verwandt ist, da Sie auf Existenz prüfen müssen, aber der nächste Schritt könnte die Verwendung des IE sein, und es könnte dafür hilfreich sein.

0
theTuxRacer