it-swarm.com.de

WampServer-Probleme nach dem Upgrade auf Windows 10

Seit dem Upgrade von Windows 7 auf Windows 10 scheint WampServer nicht zu funktionieren (alles, was in den Browser geladen wird, ist nur eine leere Seite), und selbst eine Neuinstallation behebt das Problem nicht.

Unter Apache > Service > Install Service heißt es:

Your port 80 is actually used by :

Server: Microsoft-IIS/10.0

Cannot install the Apache service, please stop this application and try again.

Press Enter to exit...

Anregungen wäre dankbar.

18
rybo111

Update: Dies scheint es dauerhaft zu beheben

  1. Suchen Sie in der Taskleiste nach "Windows-Funktionen aktivieren oder deaktivieren".
  2. Deaktivieren Sie unter "Internetinformationsdienste" die Option "WWW-Dienste", die Microsoft standardmäßig aktivieren muss (nimmt Port an).
  3. Starten Sie neu und WAMP wurde wie zuvor wieder gestartet.

Originelle Lösung

Ich kann Folgendes bestätigen, um das Problem zu beheben:

Führen Sie cmd als Administrator aus und geben Sie Folgendes ein: iisreset /stop

Dann werden Sie von Apache > Service > Install Service aufgefordert, die Eingabetaste zu drücken, um die Installation wie gewohnt durchzuführen.

Möglicherweise müssen Sie auch Folgendes installieren: http://www.Microsoft.com/en-us/download/details.aspx?id=30679

22
rybo111

Für Windows 10 Clean Install:

Wenn Sie eine Neuinstallation von Windows 10 durchgeführt haben, steht möglicherweise nicht der Word Wide Web Publishing-Dienst zur Verfügung . In diesem Fall sollte eine einfache WAMP/XAMPP-Installation problemlos funktionieren.

Wenn dies nicht der Fall ist, installieren Sie Visual C++ Redistributable und installieren Sie WAMP/XAMPP erneut.


Ich hatte ein ähnliches Problem mit WAMP. In Windows 10 TP ist der Word Wide Web Publishing-Dienst vorinstalliert. Dies bezieht sich auf IIS und Sie können es entfernen, wenn Sie es nicht benötigen.

Dies blockiert den Port 80, wodurch Apache merkwürdig agiert. Sie können Folgendes tun und es erneut versuchen.

  • Gehen Sie zu Start und geben Sie services.msc ein
  • Scrollen Sie im Fenster Dienste nach unten, um den WWW-Publishing-Dienst zu finden.
  • Klicken Sie mit der rechten Maustaste darauf und wählen Sie Stop .

Dies sollte Port 80 frei machen und ein Neustart von WAMP/XAMPP sollte Sie zum Laufen bringen!

Es gibt andere Möglichkeiten, dies zu beheben. http://praveenpuglia.com/make-wamp-work-on-windows-10-technical-preview/

3
Praveen Puglia

Nach all den möglichen Korrekturen, die alle in den Antworten im Internet erwähnt haben, als es immer noch nicht funktionierte, habe ich den fehlenden Schritt wie folgt herausgefunden:

Running wampmanager.exe as Administrator

Es ist so trivial - aber diese Antwort für jemanden zu hinterlassen, der wie ich feststeckte.

1
Nirav Zaveri