it-swarm.com.de

Ich kann vim nicht auf meinem Terminal installieren

wenn ich versuche, vim auszuführen, zeigt das Terminal Folgendes an: Das Programm 'vim' befindet sich in den folgenden Paketen:

* vim
 * vim-gnome
 * vim-tiny
 * vim-athena
 * vim-gtk
 * vim-nox
Try: Sudo apt-get install <selected package>

Also habe ich versucht, was die meisten meiner Klassenkameraden getan hatten, Sudo apt-get update und Sudo apt-get install vim, aber es hat nicht funktioniert. Das Terminal zeigt diese Meldung an, nachdem ich Sudo apt-get install vim eingegeben habe.

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package vim is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'vim' has no installation candidate

Danke für die Antworten

5
jan

Versuchen Sie, Sudo apt-get update && Sudo apt-get upgrade auszuführen, bevor Sie vim installieren. Manchmal bringen nicht aktualisierte Pakete die Installation anderer durcheinander.

2
Dmytro Sirenko

Die Meldung informiert Sie darüber, dass der Befehl vim in unterschiedlich kompilierten Binärpaketversionen verfügbar ist. Versuchen Sie Sudo apt-get install vim-gnome.

askubuntu.com - nterschied zwischen vim-gtk und vim-gnome

https://help.ubuntu.com/community/VimHowto

1
grantbow

versuche dies

Sudo apt-get update
Sudo apt-get install vim-common
1
saadlulu