it-swarm.com.de

Gvim GLib-GObject-WARNING in Ubuntu 13.10

Ich habe heute Nachmittag ein Upgrade von Ubuntu 13.04 auf Ubuntu 13.10 durchgeführt. Und wenn ich nach dem Upgrade versuche, vim vom Terminal aus zu starten, erhalte ich diese Warnungen

(gvim: 4054): GLib-GObject-WARNING **: Versuch, die Eigenschaft GnomeProgram :: sm-connect hinzuzufügen, nachdem die Klasse initialisiert wurde 
 
 (gvim: 4054): GLib-GObject-WARNING * *: Versuch, die Eigenschaft GnomeProgram :: show-crash-dialog hinzuzufügen, nachdem die Klasse initialisiert wurde 
 
 (Gvim: 4054): GLib-GObject-WARNING **: Versuch, die Eigenschaft GnomeProgram :: display hinzuzufügen nach der Initialisierung der Klasse 
 
 (gvim: 4054): GLib-GObject-WARNING **: Versuch, die Eigenschaft GnomeProgram :: default-icon nach der Initialisierung der Klasse hinzuzufügen`


Wie kann ich das beheben und worum geht es bei diesen Warnungen genau?

34
naveen.panwar

Ich habe das am 14.04 gesehen. Ich hatte aber nur vim-gnome installiert. Das Entfernen von vim-gnome und das Installieren von vim-gtk funktioniert ohne Fehlermeldungen.

Sudo apt-get -y remove vim-gnome
Sudo apt-get install vim-gtk
17
Jeff Adamson

Dies behebt Ihr Problem nicht, aber ich habe versucht, vim-gnome zu entfernen und zu installieren und hatte das gleiche Problem. Also habe ich vim-gnome entfernt und vim-gtk installiert und es funktioniert einwandfrei.

28
Brad

Um dies zu lösen, habe ich einen Alias ​​hinzugefügt, um gvim mit allen verworfenen stderr-Nachrichten auszuführen.

Fügen Sie Ihrer .bashrc -Datei einfach die folgende Zeile hinzu:

alias gvim="gvim 2>/dev/null"

Ich hasse diese Art von Fehlern und Warnungen, wenn das von mir verwendete Programm sich meiner Kontrolle entzieht und viele davon druckt, die mich von meiner Arbeit ablenken.

7
tayfun

Nachdem ich Ihre Vorschläge überprüft hatte, stellte ich fest, dass beide vim-gnome und vim-gtk installiert waren.

Dieses Problem wurde für mich gelöst, indem vim-gnome entfernt und vim-gtk einfach beibehalten wurde.

1
statueofmike