it-swarm.com.de

Die Ausgabe dieses Felds in den Ansichten 7.x-3.3 kann nicht neu geschrieben werden

Ich weiß nicht, ob mir etwas fehlt, aber wenn ich das Kontrollkästchen für Neu schreiben der Ausgabe dieses Felds oder irgendetwas unter den Stiloptionen zum Anpassen des HTML-Codes aktiviere, passiert nichts. Ich überprüfe es, speichere es, öffne es wieder und die Kästchen sind deaktiviert. Weiß jemand, was los ist?

Aus Gründen der Übersichtlichkeit bearbeitet . Ich erstelle eine neue Ansicht mit den folgenden Einstellungen: Seite, Format: Unformatierte Liste, Anzeigen: Felder, Felder ist Inhalt: Titel. In den Einstellungen für Inhalt: Titel überprüfe ich, um eine Beschriftung zu erstellen. Ich klicke unter "Stileinstellungen" Feld-HTML anpassen, Label-HTML anpassen, Feld- und Label-Wrapper-HTML anpassen oder schreibe sogar die Ausgabe dieses Feldes neu, aber es passiert nichts. Wenn ich das Kontrollkästchen speichere, wird es wieder deaktiviert

[~ # ~] Lösung [~ # ~] Verstanden. Die Ansichten 7-3.3 funktionieren nicht mit jQuqery 1.7+. Es verhindert, dass das Feld nach dem Klicken auf das Kontrollkästchen erweitert wird

Quelle: http://drupal.org/node/149486

8
Greg Somers

LÖSUNG Verstanden. Die Ansichten 7-3.3 funktionieren nicht mit jQuqery 1.7+. Es verhindert, dass das Feld nach dem Klicken auf das Kontrollkästchen erweitert wird

Quelle: http://drupal.org/node/149486

9
Greg Somers

Das gleiche Problem tritt auf, wenn Sie jQuery 1.10 oder 1.9 mit Drupal 7.31. Wenn Sie versuchen, ein Feld in einer Ansicht zu bearbeiten und Kontrollkästchen zu aktivieren, werden die relevanten Formularelemente nicht erweitert.

Eine Lösung besteht darin, das Modul jQuery Update zu verwenden, mit dem die Version von jQuery in Drupal core auf eine neuere Version von jQuery aktualisiert wird).

Laden Sie das Modul herunter, aktivieren Sie es und rufen Sie die Seite /admin/config/development/jquery_update auf. Im Dropdown-Menü "Standard-jQuery-Version" können Sie die Version von jQuery auswählen, die Sie verwenden möchten.

Ich habe die Version 1.8 jQuery ausgewählt und habe jetzt kein Problem damit, die Ansichtsfelder zu bearbeiten.

1
consuela