it-swarm.com.de

Wodurch werden Videos auf einer AMD Radeon HD 6700 schwarz oder fehlerhaft?

Ich habe kürzlich meine Grafikkartentreiber auf die neueste Version aktualisiert (AMD Radeon HD 6700-Serie) und dabei festgestellt, dass alle "GIF" auf Imgur (die jetzt auf "GIFV" umgestellt haben, einen MP4, der im Browser abgespielt wird) Um die Ladezeiten zu verkürzen und größere Uploads zu ermöglichen, werden für unterschiedliche Zeiträume schwarze und/oder fehlerhafte Frames angezeigt.

Screengrab

Links ist das Video ungefähr 2 Sekunden in. Rechts ist, wenn das Video geloopt hat. Dies passiert mit jedem GIFV, das ich auf Imgur ansehe, einer zufälligen Auswahl von YouTube-Videos, aber bisher wurden keine Videos auf meinen Windows 8 "Modern" -Anwendungen oder auf VLC abgespielt. Ich sehe dieses Problem auch auf mehreren Client-Computern, kann aber nicht herausfinden, was los ist.

Das 'Video' wird irgendwann gut, wenn es das Ende erreicht und zurückspringt (z. B. auf Bild) oder wenn sich die Szene erheblich ändert (z. B. der Kamerawinkel ändert sich, geht die Beleuchtung in der Szene von wirklich dunkel zu wirklich hell oder Die Kamera zoomt oder schwenkt auf mehr als subtile Weise.

Als Referenz verwende ich eine Karte der AMD Radeon HD 6700-Serie (ich denke, es ist die 6770, der Geräte-Manager ist nicht hilfreich und die Geräte-ID wird auch nicht im Internet gesucht). Ich verwende Windows 8.1, vollständig aktualisiert. Dies passiert in Google Chrome 39.0.2171.13 Beta-M und Firefox 32.0.3, es funktioniert gut in IE, aber dann bekomme ich wieder große Video-Steuerelemente über die Oberseite des GIFV auf Imgur, so dass ich nicht weiß, ob das die Ursache ist Szene zu "erfrischen" und die schwarzen Pannen zu vermeiden.

Was ist die Ursache dafür? Warum funktioniert es erst, wenn sich die Szene ändert, und wie kann ich das Problem beheben?

18
Grayda

Dies geschieht in Google Chrome 39.0.2171.13 Beta-M und Firefox 32.0.3, es funktioniert gut in IE.

Für mich ist das der Schlüssel. Ich frage mich, ob dies mit der 3D-Beschleunigung zu tun hat, die die Videowiedergabe durcheinanderbringt. In modernen Browsern wie Chrome, Safari und FireFox ist die Hardwarebeschleunigung des Seiteninhalts standardmäßig eingestellt.

Die Funktionsweise ist so, dass das Browserfenster in jeder Hinsicht wie eine flache Seite eines 3D-Objekts behandelt wird. Der Browser überträgt den gesamten gerenderten Inhalt über den Grafikkartentreiber und zeigt ihn auf dem Bildschirm an. Wenn alles in Ordnung ist, sieht der Inhalt genauso aus wie beim direkten Rendern des Bilds durch das System, auf komplexeren Seiten sollte er jedoch etwas schneller gerendert werden.

Ich würde in den Chrome- und Firefox-Einstellungen stöbern, um zu sehen, ob Sie die Videobeschleunigung deaktivieren können. Vielleicht sogar im Fahrer selbst? Damit würde das Video zumindest in Ihrem Browser richtig angezeigt, aber die tiefere Frage, warum Nice nicht abgespielt wird, ist noch im Gange. Das ist mir nicht klar, aber es könnte einfach ein Problem mit dem Fahrer oder sogar mit den Fahrereinstellungen sein. Vielleicht in das System graben und sehen, ob Sie die Treibereinstellungen verwerfen können, um es zu zwingen, eine neue Datei zu erstellen?

10
JakeGould

Um zu beantworten, warum Sie einen schwarzen Rahmen sehen,

Videodateien sind nicht nur aufeinanderfolgende Bilder (wie zum Beispiel das GIF-Format), sie können auf verschiedene Arten komprimiert werden. Hier ist ein cooles Video , das die hier stattfindende Komprimierung erklärt (die Erklärung sind die ersten 3 Minuten des Videos). Aus irgendeinem Grund lädt der Browser das erste Bild im Videoclip nicht richtig, sondern zeigt nur einen schwarzen Bildschirm an, sodass Sie diese schwarze Panne bekommen. Wenn Sie sofort zum Betteln übergehen oder einfach warten, bis sich die gesamte Szene geändert hat, verschwindet der Fehler, da der Player ein ganzes Bild laden musste.

8
user3454536

Hallo zusammen, ich hatte das gleiche Problem. Was für mich behoben ist, gehen Sie auf neue Registerkarte Typ Chrome: // Flags und Suche GPU-Rasterisierung MSAA-Beispielanzahl Ich hatte es auf 0, setzen Sie es auf 16 und die Probleme sind magisch behoben. (Ich habe GTX980Ti) Lassen Sie mich wissen, ob es funktioniert hat. Das Ausschalten der Hardwarebeschleunigung funktioniert ebenfalls, aber einige anspruchsvolle Dinge verzögern sich, wenn Sie nicht über eine sehr leistungsstarke CPU verfügen (Beispiel: 6K60fps-Video).

5
Romet

Ich hatte das gleiche problem Ich weiß noch nicht, ob Sie die Lösung gefunden haben, aber ich habe sie auf dieser Website gefunden:

Ich füge den Kommentar hier ein: Ich habe eine Lösung gefunden. Ich hatte bereits versucht, das Codec Pack zu installieren, aber es gab keinen Unterschied. Ich habe mich hier mit den Chromeinstellungen beschäftigt: chrome: // flags/# disable-accelerated-video-decode, und habe sie deaktiviert, um die Beschleunigung zu ermöglichen. Jetzt sieht alles gut aus. Und Videos scheinen klar zu laufen. Diese Option unterscheidet sich von der in den Chromeinstellungen, in denen die 3D-Beschleunigung deaktiviert ist.

Bei mir hat es funktioniert! Seltsam!

3
user519486

Ein Fix, den ich für Chrome gefunden habe, hat Ihre Flags (chrome: // flags in einem neuen Tab) durchsucht und Hardware-accelerated video decode deaktiviert.

1
hi im b

Mein Laptop tat das gleiche. Ich ging in die Google Chrome-Einstellungen, dann in die erweiterten Einstellungen, bis zum System und deaktivierte das Kontrollkästchen für die erweiterte Beschleunigung. Ich habe dann Chrome neu gestartet und jetzt ist alles in Ordnung.

0
tommy campbell