it-swarm.com.de

Site läuft auf neuem Server langsam?

Ich habe kürzlich eine Website auf einen neuen 123-reg-Server in einer einzelnen WP Installation hochgeladen (www.moseleycoachsales.co.uk). Ich hatte die Site in meiner eigenen gehosteten Multisite-Umgebung entwickelt ( http://test.digitalgroupmedia.com/moseley/ ).

Ich hatte einen Albtraum beim Hochladen der Website, da die standardmäßige WordPress-XML-Export-/Importfunktion, die immer für mich funktioniert hatte, immer wieder abstürzte. Am Ende habe ich es geschafft, die Website mit dieser Methode live zu bringen ( http://matteth.wordpress.com/2012/01/12/exporting-a-site-from-multisite-to -einzelinstallation/ )

Die Live-Website ist jetzt sehr träge und bei weitem nicht so schnell wie in meiner Testumgebung. Ich weiß nicht, ob dies auf den neuen Server zurückzuführen ist oder ob beim Verschieben der Website (möglicherweise datenbankbezogen) ein Fehler aufgetreten ist, der das Problem verursacht hat.

Ich bin nicht besonders gut mit MySQl, habe also nicht wirklich die Fähigkeit, dieses Problem zu diagnostizieren (wenn es überhaupt das Problem ist) und würde mich über Hilfe sehr freuen.

Ihre Website ist mit über 4 Megabyte sehr, sehr schwer. Erleichtere es; siehe http://gtmetrix.com/reports/www.moseleycoachsales.co.uk/eyz4qxQx

Korrigieren Sie die Codefehler, z. B. dass Sie keine Bildabmessungen angeben, Ihre Bilder nicht richtig skalieren, Ihre Bilder nicht optimieren, das Browser-Caching einstellen und Header verfallen lassen usw.

Ihre Websitegeschwindigkeit hat sehr wenig mit einer 404 für ein Stylesheet zu tun. Verwenden Sie Firebug mit Firefox oder verwenden Sie die Entwicklertools in Chrome oder Safari oder DH , um zu sehen, was auf Ihrer Website geladen wird.

Ihre Datenbank ist möglicherweise aufgrund von Überarbeitungen übergroß, und in Ihrem Design werden möglicherweise mehr als die durchschnittliche Anzahl von Abfragen verwendet. Verwenden Sie http://wordpress.org/plugins/debug-queries/ und http://wordpress.org/plugins/rvg-Optimize-database/

Und jeder billige Host da draußen ist langsam. Überprüfen Sie http://www.google.com/search?&q=123-reg+slow

1
markratledge

In deinem Kopf hast du <link rel="stylesheet" href="css/bootstrap.css">. Dies versucht und schlägt fehl, bootstrap.css unter Verwendung einer relativen URL zu laden.

Ich würde das Debug-Leisten-Plugin installieren und versuchen, zu sehen, was los ist, aber wenn das nicht in Ihrer Komfortzone liegt, sollte der erste Schritt darin bestehen, Kontakt mit Ihrem aufzunehmen Host und fragen, ob sie helfen können.

0
vancoder

das Öffnen Ihrer Homepage beansprucht ca. 3,5 MB Bandbreite. Sie müssen diese reduzieren.

  1. Verwenden Sie das WP Smush.it-Plugin, um Ihr Bild zu optimieren.
  2. Komprimieren Sie Ihre .js- und .css-Datei über diese Site. http://cssminifier.com/
  3. Ich denke, Sie müssen css/bootstrap.css aus Ihrer Header-Datei entfernen, da es eine Mindestversion dieser Datei gibt.
  4. Verwenden Sie das Cache-Plugin wie w3 total cache oder wp super cache.
0
ahmetlutfu