it-swarm.com.de

Medien können nicht hochgeladen werden, Berechtigungen sind korrekt

Ich habe eine manuelle Sicherung und Neuinstallation einer WP Site durchgeführt, und es hat einwandfrei funktioniert. Dann hat mein Client einige Plugins aktualisiert, es bereut und mich gebeten, den vorherigen Status der Site wiederherzustellen. Ich habe das gleiche Backup verwendet, das ich vom ersten Mal hatte, aber jetzt hat sich herausgestellt, dass mein Client keine Medien hochladen kann.

Ich gehe auf die Website, um zu versuchen, ein Bild hochzuladen, und es werden keine Fehlermeldungen angezeigt, als hätte das Bild einwandfrei hochgeladen. Anstelle der normalen Vorschau wird jedoch ein fehlerhaftes Bildsymbol angezeigt. Wenn ich dem Bildlink folge, wird die Meldung "Seite nicht gefunden (404)" angezeigt. Der URL-Pfad ist der Pfad, in den das Bild hochgeladen werden sollte. Überprüfen Sie jedoch den FTP-Ordner, in dem sich das Bild nicht befindet.

Alle Ordner haben 755 Berechtigungen (alle Dateien sind 644). Ich habe versucht, die Ordner auf 777 zu ändern (nur zum Testen), aber ohne Erfolg. Ich erhalte immer noch ein defektes Bildsymbol und es werden keine Bilder in den aktuellen Ordner hochgeladen.

Der einzige Ort, an dem ich das Bild sehen kann, ist, wenn ich zur Bearbeitungsoption gehe (und erneut auf Bearbeiten klicke), dass ich es im Bearbeitungstextbereich sehen kann. Wenn ich dasselbe Bild in einem neuen Tab öffne, lautet die URL etwa mysite.com/blog/wp-admin/admin-ajax.php?action=imgedit-preview [...].

Ich habe vor dem Posten einige Fragen durchsucht, aber die meisten wurden gelöst, indem ich die Berechtigungen hin und her änderte, oder es war ein Problem zwischen den Benutzer- und Eigentümerberechtigungen. Ich habe das erste ausprobiert und es hat nicht funktioniert, und das zweite trifft meiner Meinung nach nicht wirklich zu, da die Site beim ersten Mal unter demselben Benutzer wie jetzt einwandfrei funktioniert hat. Das Problem ist so ziemlich das gleiche wie bei dieser Frage , außer dass ich keine .htaccess-Datei im Weg habe.

Hat jemand eine Idee woran das liegen könnte?

6
brunn

Ich habe das Problem gefunden. Unter settings> media zeigte der Ordner für Uploads tatsächlich auf einen anderen Pfad. Sobald ich es zu wp-content/uploads umgeleitet habe, hat alles funktioniert.

12
brunn

Wenn Sie Ihre Seite von einem Host auf einen anderen verschoben haben, überprüfen Sie, ob der Upload-Pfad zu Ihrem neuen Host korrekt ist (und nicht ein Überbleibsel des vorherigen Hosts).

Navigieren Sie zu: http: //YOURDOMAIN/wp-admin/options.php

Suchen Sie das Feld für "upload_path" und überprüfen Sie es.

5
BeTA iT

Können Sie immer noch auf die Einstellung zugreifen, um den Ordner für Medien-Uploads zu ändern? Ich habe eine Site geklont und konnte einen langen Verzeichnisnamen auf der Seite Einstellungen> Medien sehen.

Ich habe es in "wp-content/uploads" geändert und gespeichert - an diesem Punkt wurde das Eingabefeld entfernt! Es scheint, dass die Funktion in WP3.6m entfernt wurde und jetzt nur noch in WP-config oder in der Datenbank über phpMyAdmin geändert werden kann

0
Malcolm Morris