it-swarm.com.de

versuchen, Pakete zu aktualisieren

Ich habe versucht, meine Pakete zu aktualisieren, möchte aber kein Upgrade auf 16.10 durchführen. Ich habe Sudo apt update und dann Sudo apt upgrade ausgeführt, um meine Pakete zu aktualisieren, aber diese Meldung im Terminal erhalten

The following packages have unmet dependencies:
 libcjs0e : Conflicts: libcjs0 but 3.0.1-3build2 is to be installed
 python3-aptdaemon.pkcompat : Conflicts: packagekit
                              Conflicts: packagekit:i386

Sollte ich diese Pakete löschen/entfernen und neu installieren? Vielen Dank im Voraus für Ihre Hilfe.

8
Jorge Santiago

Ich tat dies:

Sudo apt-get purge python3-aptdaemon.pkcompat
Sudo apt-get update
Sudo apt-get upgrade
reboot

# after reboot
Sudo do-release-upgrade

Das Paket python3-apt-daemon.pkcompat hatte keine Abhängigkeiten mehr. Das Upgrade verlief dann normal.

9

Dies löste mein Problem in jeder Situation :) ausführen:

Sudo apt-get -f autoremove
Sudo apt-get update

dann versuche es nochmal:

Sudo apt-get upgrade
3
Favian Ioel P

Mein Upgrade von 14.04 über 16.04 auf 18.04 ist aus dem gleichen Grund fehlgeschlagen. Michaels Lösung hat funktioniert, als ich apt anstelle von apt-get verwendet habe.

Sudo apt purge python3-aptdaemon.pkcompat
Sudo apt update
Sudo apt upgrade

"apt upgrade" ist teilweise fehlgeschlagen, wurde jedoch größtenteils abgeschlossen, als ich einen nachfolgenden Befehl "apt purge" ausführte.

1
user2145748