it-swarm.com.de

Upgrade auf 3.4 Fehler: Aufruf der undefinierten Funktion get_option ()

Nach dem Ausführen des automatischen Upgrades auf 3.4 erhalte ich die Nachricht

Schwerwiegender Fehler: Rufen Sie die undefinierte Funktion get_option () in /.../wp-admin/admin.php in Zeile 32 auf

Ich habe Plugins/in Plugins2/umbenannt, Themes/in Themes2/umbenannt, Themes/erstellt und dort zwanzig eingefügt.

Scheitert immer noch mit dem gleichen Fehler.

Ich habe eine Kopie von 3.4 heruntergeladen und/wp-admin und/wp-includes hochgeladen.

Scheitert immer noch mit dem gleichen Fehler.

Wenn ich versuche, wp-admin/upgrade.php auszuführen, erhalte ich:

"Schwerwiegender Fehler: Aufruf der undefinierten Funktion timer_start () in /.../wp-admin/upgrade.php in Zeile 20"

Zeile 32 von /wp-admin/admin.php lautet:

if ( get_option('db_upgraded') ) {

Ich habe versucht, diese auf true gesetzte Option manuell in die Tabelle wp_options in phpmyadmin einzufügen, aber der gleiche Fehler bleibt bestehen.

1
Steve

Das Problem wurde durch ca. 8 WordPress-Dateien im Stammverzeichnis mit einer Dateigröße von 0 Byte verursacht.

Das Hochladen neuer Kopien dieser Dateien (von der neuesten von wordpress.org heruntergeladenen Version) löste das anfängliche Problem.

Das nachfolgende Problem ist seitdem behoben, ohne dass angegeben wurde, welche Schritte es lösten.

0
Steve