it-swarm.com.de

Kein Sound in Ubuntu 18.04 LTS nach dem Upgrade von 16.04 LTS

Ich habe gerade meinen Ubuntu-Desktop 16.04 LTS auf 18.04 LTS aktualisiert. Danach werden keine Audiogeräte mehr erkannt. Ich habe Lenovo Laptop. Settings/Sound/Output

Settings/Sound/Input

Ich habe diese versucht ..
1.

Sudo apt-get remove --purge alsa-base pulseaudio
Sudo apt-get install alsa-base pulseaudio pavucontrol
Sudo alsa force-reload
reboot

2.

Sudo apt-get install pavucontrol
pavucontrol

pavucontrol 3.

$ Sudo lspci
[Sudo] password for surjit: 
00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 0b)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 0b)
00:14.0 USB controller: Intel Corporation 8 Series USB xHCI HC (rev 04)
00:16.0 Communication controller: Intel Corporation 8 Series HECI #0 (rev 04)
00:1b.0 Audio device: Intel Corporation 8 Series HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 3 (rev e4)
00:1c.3 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 4 (rev e4)
00:1d.0 USB controller: Intel Corporation 8 Series USB EHCI #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation 8 Series LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 8 Series SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 8 Series SMBus Controller (rev 04)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 10)
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter

Bitte helfen Sie

15
surjit

Ich hatte ein ähnliches Problem, das sich als Berechtigungsproblem mit der Pulse Audio Conf-Datei herausstellte, als ich letztes Jahr mein Lenovo T440pclaptop auf 17.10 aufrüstete.
Das Update, das schließlich für mich funktioniert hat (Entschuldigung, ich kann die Originalquelle nicht finden), war

killall pulseaudio; rm -r ~/.config/Pulse/*

hth

37
SeanSNZ

Ich hatte das gleiche Problem - nach dem Upgrade auf 18.04.1 LTS war kein Ton zu hören - und es wurden keine Audioprofile angezeigt. Dies löste schließlich das Problem:

  1. lösche .config/Pulse/und .Pulse (letzteres existiert möglicherweise nicht)
  2. neustarten
  3. pulseaudio --start
  4. pavucontrol, gehen Sie zur Registerkarte Configuration und wählen Sie das Profil Analog Stereo Output
  5. gnome-alsamixer Stummschaltung aufheben

Ich weiß nicht, ob all diese Schritte notwendig sind, aber nur das Beenden von pulseaudio und das Entfernen der Pulse-Konfigurationsdateien haben das Problem nicht behoben. Ohne den Neustart war alsamixer bereits nicht stummgeschaltet, es war jedoch kein Ton zu hören.

2
Norbert S

Neben dem Löschen von pulseaudio und pulseaudio-utils und seinen lokalen Lonfigs musste ich auch alle lokalen gstreamer-Konfigurationen entfernen. Dies war auf einem Dell Latitude E5570.

apt purge pulseaudio.*
rm -r ~/.config/Pulse/ ~/.cache/gstreamer-1.0/ ~/.local/share/gstreamer-1.0/
apt install pulseaudio
0
P.Péter