it-swarm.com.de

Warum sind die automatischen Updates für Wordpress hinter der Version, auf der sich meine Site befindet?

Ich habe regelmäßig Nachrichten erhalten, dass meine WordPress-Site automatisch aktualisiert wurde. Die letzte ist heute eingetroffen und sagt, dass sie automatisch auf WordPress 4.4.4 aktualisiert wurde.

Meine Website ist derzeit auf Wordpress 4.5.3.

Ich habe zweimal nachgesehen, dass dies eine legitime E-Mail ist und sie über die Website auf dem richtigen Server eingegangen ist. Sie ist echt. Warum wird meine Website automatisch rückwärts aktualisiert?

2
Faye

Websites auf früheren Nebenversionen (der mittlere Punkt in der Versionsnummer) werden im Allgemeinen automatisch auf neue Patchversionen (der letzte Punkt) aktualisiert, wenn eine vorhanden ist Sicherheitsfreigabe.

Beispielsweise kann eine Site unter 4.4.3 automatisch auf 4.4.4 aktualisiert werden, wenn ein Sicherheitspatch für 4.5.2 bis 4.5.3 veröffentlicht wurde. Dies bedeutet, dass Sicherheitspatches automatisch angewendet werden können, während kleinere Versions-Upgrades von Ihnen selbst initiiert werden.

Dies erklärt jedoch nur, warum eine Site möglicherweise automatisch auf eine frühere Version aktualisiert wurde - es erklärt nicht, was in Ihrer Instanz geschehen ist.

Es ist sehr unwahrscheinlich, dass WordPress tatsächlich E-Mails verschickt, die besagen, dass es auf eine alte Versionsnummer aktualisiert wurde, wenn Sie die neueste Version verwenden. Dies kann auf eine Reihe von esoterischen Dingen zurückzuführen sein, z. B. darauf, dass eine alte Upgrade-E-Mail irgendwo in der Spool Ihres Mailservers hängen bleibt.

Wenn Sie befürchten, dass Sie gehackt wurden, würde ich einen Vergleich mit der neuesten Version von WordPress anstellen, um sicherzustellen, dass alles intakt ist. Trotzdem ist es sehr unwahrscheinlich, dass ein Hack gefälschte Upgrade-E-Mails verschickt ...

EDIT: Ich kann es auf der WordPress-Site nicht finden, abgesehen von im Archiv , aber 4.4.4 war wahrscheinlich die Sicherheitsversion, die 4.5.3 entsprach, da jetzt zwei vorhanden sind Sicherheitsversionen für 4.5.x und 4.4.2 waren die letzten offiziellen Versionen der 4.4.x-Reihe.

3
Tim Malone