it-swarm.com.de

Wie wird die Certbot-Version aktualisiert?

Ich führe certbot --Apache aus, erhalte jedoch die folgende Fehlermeldung:

Starting new HTTPS connection (1): acme-v01.api.letsencrypt.org
Obtaining a new certificate
Performing the following challenges:
Client with the currently selected authenticator does not support any 
combination of challenges that will satisfy the CA.

Die installierte Version ist 0.10.2 unter Debian 8.10

Ich möchte ein Upgrade auf 0.21.0 durchführen, um das Problem zu beheben https://community.letsencrypt.org/t/certbot-0-21-0-release/50725

ich habe jedoch apt-get Update/Upgrade ausprobiert und erhalte Folgendes:

certbot is already the newest version.
certbot set to manually installed.

Anregungen zur Aktualisierung?

13
xylar

Nicht sicher, wie ich das vermisst habe. Aus den Installationsdokumenten https://certbot.eff.org/docs/install.html#certbot-auto

[email protected]:~$ wget https://dl.eff.org/certbot-auto
[email protected]:~$ chmod a+x ./certbot-auto
[email protected]:~$ ./certbot-auto --help
14
xylar

Ein bisschen Hintergrund von Let's Encrypt

Leider hat Let's Encrypt nicht mehr den Mechanismus angeboten, den die Apache- und Nginx-Plugins von Certbot verwenden, um zu beweisen, dass Sie eine Domäne aufgrund eines Sicherheitsproblems kontrollieren

Um dies auf einer vorhandenen L.E-Installation vor den Updates zu umgehen, folgen Sie dieser Lösung , wenn Sie Debian/Ubuntu verwenden:

certbot --authenticator standalone --installer Apache -d <yourdomain(s)> --pre-hook "Apache2ctl stop" --post-hook "Apache2ctl start
1
Theson

Verwenden Sie bei debian Stretch einfach:

apt-get install python-certbot-Apache -t stretch-backports
1
Henrik

Verwenden Sie unter MacOS den folgenden Befehl, um certbot zu installieren:

brew install certbot

Wenn Sie certbot bereits installiert haben, verwenden Sie den folgenden Befehl zum Upgrade

brew upgrade certbot
0
Saeed D.