it-swarm.com.de

Ppa kann nicht auf Ubuntu 15.10 hinzugefügt werden

Ich habe gerade das Ubuntu 15.10 installiert und versuchte einige Apps zu installieren. Ich kann aber kein Repository-ppa hinzufügen. Jedes Mal heißt es, "Benutzer oder Team existiert nicht.".

Sudo add-apt-repository ppa:noobslab/nemo
Cannot add PPA: 'ppa:~noobslab/ubuntu/nemo'.
ERROR: '~noobslab' user or team does not exist.

Bitte schlagen Sie eine Lösung für dieses Problem vor.

Edit: Ich spreche nicht von diesem spezifischen PPA, jedes Mal für jedes PPA sagt es dasselbe ... 

Sudo apt-add-repository -y ppa:teejee2008/ppa
Cannot add PPA: 'ppa:~teejee2008/ubuntu/ppa'.
ERROR: '~teejee2008' user or team does not exist

oder

Sudo add-apt-repository ppa:noobslab/themes
Cannot add PPA: 'ppa:~noobslab/ubuntu/themes'.
ERROR: '~noobslab' user or team does not exist.

.

6
Eular

Das Problem für meine Installation gefunden: Proxy-Server mit Authentifizierung, siehe hier: https://askubuntu.com/questions/724224/cant-add-ppa-on-ubuntu-15-10

Dies führt zu dieser fehlgeleiteten Fehlermeldung. Dies kann aber auch jeder Fehler beim Abrufen der Daten sein. Zum Debuggen habe ich die Datei geändert:

/usr/lib/python3/dist-packages/softwareproperties/ppa.py 

Und im catch-Fall der Funktion def _get_https_content_py3 (lp_url) wurde ein Print (e) hinzugefügt.

Was zeigt mir den wahren Grund.

8
Sven

Ich hatte das gleiche Problem. Es stellt sich heraus, dass das Datum auf meinem System falsch eingestellt wurde. Dies zeigt, wenn ich versuche, die ppa manuell zu wget:

$ wget https://launchpad.net/~ubilinux/+archive/ubuntu/up
--2016-02-11 17:41:18--  https://launchpad.net/~ubilinux/+archive/ubuntu/up
Resolving launchpad.net (launchpad.net)... 91.189.89.223, 91.189.89.222
Connecting to launchpad.net (launchpad.net)|91.189.89.223|:443... connected.
ERROR: cannot verify launchpad.net's certificate, issued by ‘CN=DigiCert SHA2 Extended Validation Server CA,OU=www.digicert.com,O=DigiCert Inc,C=US’:
  Issued certificate not yet valid.
To connect to launchpad.net insecurely, use `--no-check-certificate'.

Das Datum auf meinem System war ein Jahr hinterher. Durch die Korrektur des Datums wird das Problem gelöst. Https://askubuntu.com/questions/679988/how-to-change-ubuntus-server-date-and-time-via-command-line

3
Frank Kusters

Ich denke, dass das PPA nur für Ubuntu 14.04, 14.10 und 15.04 funktioniert. Wenn Sie den Nemo-Dateimanager für Ubuntu herunterladen möchten (verwenden Sie diesen PPA nicht, wenn Sie Linux Mint oder Cinnamon unter Ubuntu verwenden), probieren Sie die folgenden Befehle:

Sudo add-apt-repository ppa:webupd8team/nemo
Sudo apt-get update
Sudo apt-get install nemo nemo-fileroller

Für weitere Informationen lesen Sie diesen Beitrag .