it-swarm.com.de

Mein apt wurde durch die Installation von Boost versaut

Auf Ubuntu

#> Sudo apt-get install libboost-all-dev

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies.
 libboost-all-dev : Depends: libboost-dev but it is not going to be installed
                    Depends: libboost-atomic-dev but it is not going to be installed
                    Depends: libboost-chrono-dev but it is not going to be installed
                    Depends: libboost-context-dev but it is not going to be installed
                    Depends: libboost-date-time-dev but it is not going to be installed
                    Depends: libboost-exception-dev but it is not going to be installed
                    Depends: libboost-filesystem-dev but it is not going to be installed
                    Depends: libboost-graph-dev but it is not going to be installed
                    Depends: libboost-graph-parallel-dev but it is not going to be installed
                    Depends: libboost-iostreams-dev but it is not going to be installed
                    Depends: libboost-locale-dev but it is not going to be installed
                    Depends: libboost-math-dev but it is not going to be installed
                    Depends: libboost-mpi-dev but it is not going to be installed
                    Depends: libboost-mpi-python-dev but it is not going to be installed
                    Depends: libboost-program-options-dev but it is not going to be installed
                    Depends: libboost-python-dev but it is not going to be installed
                    Depends: libboost-random-dev but it is not going to be installed
                    Depends: libboost-regex-dev but it is not going to be installed
                    Depends: libboost-serialization-dev but it is not going to be installed
                    Depends: libboost-signals-dev but it is not going to be installed
                    Depends: libboost-system-dev but it is not going to be installed
                    Depends: libboost-test-dev but it is not going to be installed
                    Depends: libboost-thread-dev but it is not going to be installed
                    Depends: libboost-timer-dev but it is not going to be installed
                    Depends: libboost-wave-dev but it is not going to be installed
 libboost-chrono1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not going to be installed
 libboost-date-time1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not going to be installed
 libboost-exception1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not going to be installed
 libboost-filesystem1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not going to be installed
 libboost-graph-parallel1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not going to be installed
 libboost-graph1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not going to be installed
 libboost-iostreams1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not going to be installed
 libboost-locale1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not going to be installed
 libboost-log1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not going to be installed
 libboost-math1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not going to be installed
 libboost-mpi1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not going to be installed
 libboost-program-options1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not going to be installed
 libboost-python1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not going to be installed
 libboost-random1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not going to be installed
 libboost-regex1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not going to be installed
 libboost-serialization1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not going to be installed
 libboost-signals1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not going to be installed
 libboost-system1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not going to be installed
 libboost-test1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not going to be installed
 libboost-thread1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not going to be installed
 libboost-timer1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not going to be installed
 libboost-wave1.54-dev : Depends: libboost1.54-dev (= 1.54.0-2ubuntu3) but it is not going to be installed
 libboost1.54-all-dev : Depends: libboost1.54-dev but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Diese letzte Zeile: Versuchen Sie 'apt-get -f install' ohne Pakete (oder geben Sie eine Lösung an).

Okay.

#> Sudo apt-get -f install

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libboost-atomic1.53.0 libboost-chrono1.53.0 libboost-context1.53.0 libboost-graph-parallel1.53.0 libboost-graph1.53.0 libboost-iostreams1.53.0 libboost-math1.53.0 libboost-mpi1.53.0 libboost-python1.53.0 libboost-random1.53.0
  libboost-serialization1.53.0 libboost-signals1.53.0 libboost-test1.53.0 libboost-timer1.53.0 libboost-tools-dev libboost-wave1.53.0 libboost1.53-tools-dev openjdk-7-jre-lib
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libboost1.54-dev
Suggested packages:
  libboost1.54-doc libboost-coroutine.54-dev libboost-log.54-dev doxygen default-jdk fop
The following NEW packages will be installed
  libboost1.54-dev
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
51 not fully installed or removed.
Need to get 0 B/10.3 MB of archives.
After this operation, 101 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 253168 files and directories currently installed.)
Unpacking libboost1.54-dev (from .../libboost1.54-dev_1.54.0-2ubuntu3_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libboost1.54-dev_1.54.0-2ubuntu3_i386.deb (--unpack):
 trying to overwrite '/usr/share/boostbook/xsl/docbook-layout.xsl', which is also in package libboost1.53-tools-dev 1.53.0-6+exp3ubuntu8
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libboost1.54-dev_1.54.0-2ubuntu3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Wie komme ich aus diesem Schlamassel heraus? Vielen Dank.

11
spraff

Einige Befehle sind redundant, aber für eine gute Maßnahme:

Sudo apt-get --purge remove libboost-all-dev libboost-dev libboost-doc
Sudo apt-get install -f
Sudo dpkg --configure -a
Sudo apt-get clean
Sudo apt-get update
Sudo apt-get install libboost1.54-dev

Seien Sie vorsichtig bei apt-get clean - es löscht das lokale Repo von abgerufenen Paketen in /var/cache/apt/archives. Sie sollten dort weder etwas gespeichert haben, noch Anwendungen, aber Sie sollten nur wissen, dass der Cache weg ist.

9
mockinterface

dieses Repo https://launchpad.net/~boost-latest/+archive/ubuntu/ppa enthält alle Versionen von libboost und hat es für mich behoben!

Sudo add-apt-repository ppa:boost-latest/ppa Sudo apt-get update

jetzt können Sie die gewünschte Version installieren. Die neueste Version ist 1.55:

Sudo apt-get install libboost1X.55-all-dev

2
Ruben de Vries

Ich hatte gerade dasselbe Problem. Um es zu lösen

  1. Laden Sie das Paket libboost1.54-dev von der Ubuntu-Paketseite herunter
  2. Überschreiben von Konflikten durch erzwingen

    Sudo dpkg -i --force-überschreiben libboost1.54-dev_1.54.0-2ubuntu3_AMD64.deb

  3. Dann installieren Sie Pakete, die fehlgeschlagen sind

    Sudo apt-get install -f

  4. Boost 1.53 mit entfernen

    Sudo apt-get automatisch entfernen

2
edwardtoday

Für mich funktionierte es, die Pakete manuell zu installieren, die "nicht installiert werden" (in dieser Reihenfolge):

Sudo apt-get install libboost1.46-dev Sudo apt-get install libboost-dev Sudo apt-get install libboost-all-dev

Die Installation funktioniert gut, aber ich habe nicht getestet, ob das Paket noch funktioniert. 

1
Mattia

Ich habe anfangs den Vorschlag von mockinterface ausprobiert und durchgehalten, habe aber immer noch das Problem.

Schließlich habe ich überprüft, dass der Fehler auf dem Paket lag: libboost1.54-dev_1.54.0-2ubuntu3_AMD64.deb

Also lief ich: Sudo dpkg -i --force-overwrite /var/cache/apt/archives/libboost1.54-dev_1.54.0-2ubuntu3_AMD64.deb

Ich habe dann apt-get update und apt-get upgrade ausgeführt und alles war wieder zufrieden mit dem System.

Das Upgrade von apt-get ist wichtig, da die verschiedenen Bibliotheken wieder ordnungsgemäß eingerichtet werden.

1
novogeek

Ich habe versucht, was @mockinterface war, aber mit synaptic. Hat, wo immer möglich, irgendetwas entfernt, das boost erwähnte, und notiert, was getötet wurde (seltsamerweise aptitude), um es später erneut zu installieren.

Dann, als @Igor R. in einem Kommentar vorschlug, boost aus der Quelle.

Zu diesem Zeitpunkt war /usr/local/lib/liboost*.so* voll mit Zeug, von dem ich glaube, dass er später als das Debian/Ubuntu-Repository erschien.

Es scheint jedoch ein großes Unterfangen zu sein, all von boost zu entfernen, da libreoffice, compiz und unit von libboost-date-time1.54.0, libboost-program-options1.46.1 und libboost-serialization1.46. abhängen.

0
isomorphismes
Sudo aptitude install libboost1.55-all-dev

Das hat endlich für mich funktioniert.

0
AidenX