it-swarm.com.de

Keine DNS-Auflösung nach dem Upgrade von Ubuntu 14.04 auf 16.04

Ich habe Ubuntu 14.04 auf Ubuntu 16.04 aktualisiert und habe ein Problem mit der Internetverbindung. Insbesondere funktionierte DNS nach dem Update nicht mehr. Zum Debuggen habe ich das einzige DNS 8.8.8.8, aber die Namensauflösung funktioniert immer noch nicht. Die Ausgabe von nmcli device show wlan1 | grep IP4 ist:

[email protected]:~$ nmcli device show wlan1 | grep IP4
IP4.ADDRESS[1]: 192.168.1.3/24
IP4.GATEWAY: 192.168.1.1
IP4.ROUTE[1]: dst = 169.254.0.0/16, nh = 0.0.0.0, mt = 1000
IP4.DNS[1]: 8.8.8.8
The output from Dig @8.8.8.8 google.com and Dig google.com:

Dig @8.8.8.8 google.com
; <<>> Dig 9.10.3-P4-Ubuntu <<>> @8.8.8.8 google.com
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 60075
;; flags: qr rd ra; QUERY: 1, ANSWER: 12, AUTHORITY: 0, ADDITIONAL: 1
;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;google.com.            IN  A

;; ANSWER SECTION:
google.com.     27  IN  A   62.75.23.245
google.com.     27  IN  A   62.75.23.230
google.com.     27  IN  A   62.75.23.216
google.com.     27  IN  A   62.75.23.238
google.com.     27  IN  A   62.75.23.224
google.com.     27  IN  A   62.75.23.223
google.com.     27  IN  A   62.75.23.237
google.com.     27  IN  A   62.75.23.210
google.com.     27  IN  A   62.75.23.217
google.com.     27  IN  A   62.75.23.231
google.com.     27  IN  A   62.75.23.244
google.com.     27  IN  A   62.75.23.251

;; Query time: 89 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Sat Apr 30 19:39:24 EEST 2016
;; MSG SIZE  rcvd: 231
[email protected]:~$ Dig google.com
; <<>> Dig 9.10.3-P4-Ubuntu <<>> google.com
;; global options: +cmd
;; connection timed out; no servers could be reached
[email protected]:~$ route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG    600    0        0 wlan1
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 wlan1
192.168.1.0     0.0.0.0         255.255.255.0   U     600    0        0 wlan1
11
c_nikol

Ich löse das Problem mit Amrish-Anweisungen at Ask Ubunt Stack Exchange, d. H. Mit dem folgenden Code:

Sudo rm /etc/resolv.conf
Sudo ln -s ../run/resolvconf/resolv.conf /etc/resolv.conf
Sudo resolvconf -u
9
c_nikol

Ich hatte ein ähnliches Problem und verwendete die Lösung von hier . Unten ist die Methode und ein weiterer Link, wo sie die Informationen gefunden haben -

Das DNS-Verhalten während der OpenVPN-Verbindung verbesserte sich sofort, als ich einem Vorschlag zu buntuforums folgte:

  1. Öffnen Sie /etc/NetworkManager/NetworkManager.conf in einem Editor mit Root-Rechten.
  2. Löschen (oder kommentieren Sie mit einem Hash #) die Zeile mit der Aufschrift dns=dnsmasq.
  3. Starten Sie NetworkManager über Sudo service NetworkManager restart.
6
FineJ

Ich hatte das gleiche Problem mit resolvconf verhindern, dass der DHCP-Client (dhclient) IP vom DHCP-Server für eth0 erhält. Durch Lösen des Problems resolvconf wurde das DHCP-Problem behoben.

Sudo mkdir -p /run/resolvconf/interface
Sudo resolvconf -u
Sudo service resolvconf restart
3
TheCodeKiller