it-swarm.com.de

Wie installiere ich popper.js mit Bootstrap 4?

Nach allem, was ich bisher gelesen habe, ist popper.js mit Bootstrap 4 ein großer Schmerz. Ich kann nicht, dass es funktioniert. Ich bekomme diesen Fehler immer wieder:

Fehler: Bootstrap-Dropdown erfordert Popper.js ( https://popper.js.org )

Ich habe die CDN- und NPM-Installation ausprobiert. Gleiches Ergebnis Am Ende meiner HTML-Datei habe ich Folgendes für die NPM-Installation:

<script src="js/jquery.min.js"></script>
<script src="js/popper.min.js"></script>
<script src="js/tether.min.js"></script>
<script src="js/bootstrap.min.js"></script>

Dann probierte dies für das CDN:

<script src="/js/jquery.min.js"></script>
<script src="/js/tether.min.js"></script>
<script src="https://cdnjs.com/libraries/popper.js"></script>
<script src="/js/bootstrap.min.js"></script>

Irgendwelche Ideen, was ich falsch mache?

21
4thSpace

https://cdnjs.com/libraries/popper.js sieht nicht aus wie ein rechter src für popper und gibt die Datei nicht an 

mit bootstrap 4 verwende ich dies 

<script src="https://cdnjs.cloudflare.com/ajax/libs/popper.js/1.11.0/umd/popper.min.js" integrity="sha384-b/U6ypiBEHpOf/4+1nzFpr53nxSS+GLCkfwBdFNTxtclqqenISfwAzpKaMNFNmj4" crossorigin="anonymous"></script>

und es funktioniert einwandfrei, probieren Sie es aus

7
Sam Hajari

Bootstrap 4 hat zwei Abhängigkeiten: jQuery 1.9.1 und popper.js 1.12.3. Wenn Sie Bootstrap 4 installieren, müssen Sie diese beiden Abhängigkeiten installieren.

Für Bootstrap 4.1

39
Jobayer Ahmmed

Versuchen Sie folgendes:

npm install bootstrap jquery popper.js --save

Weitere Informationen finden Sie auf dieser Seite: how-to-include-bootstrap-in-your-project-with-webpack

13
Pawel Nieradka

Ich hatte Probleme, es zu installieren Bootstrap, also habe ich getan:

Installieren Sie popper.js:npm install [email protected]^1.12.3 --save

jQuery installieren:npm install [email protected] --save

Dann hatte ich bei der Installation von [email protected] eine Meldung mit hohem Schweregrad und bekam diese Meldung:

lauf npm audit fix, um sie zu reparieren, oder npm audit für Details

So tat ich npm audit fix und nach einem anderen npm audit fix --force es wurde erfolgreich installiert!

2
DavidLio

Pawel und Jobayer hat bereits erwähnt, wie man popper.js über npm installiert.

Wenn Sie den Front-End-Paketmanager wie Bower verwenden. Verwenden Sie den folgenden Befehl

bower install popper.js --save
0
Harsha Vardhan

Hier ist eine Problemumgehung:

  1. Erstellen Sie ein js-Verzeichnis in demselben Verzeichnis wie Ihre index.html
  2. Laden Sie popper.min.js von der folgenden Site in das js-Verzeichnis herunter https://github.com/FezVrasta/popper.js#installation

beispiel : https://unpkg.com/popper.js/dist/umd/popper.min.js

  1. Ändern Sie die src Ihres Skript-Include wie folgt:

    src = "js/popper.min.js"

Beachten Sie, dass Sie Popper aus der Versionskontrolle von npm entfernt haben, sodass Sie Updates manuell herunterladen müssen.

0
kmiklas