it-swarm.com.de

Ubuntu 15.10 / 16.04 Theme ändert sich nicht

Deshalb habe ich versucht, mein Ubuntu 15.10 auf ein anderes Theme oder Icon-Theme umzustellen. Beides hat nicht oder nur teilweise funktioniert. Bei den meisten Versuchen wurde nur die obere Leiste geändert (manchmal mit fehlenden Symbolen) und manchmal die Startleiste. Wenn ich Nautilus mit Sudo starte, ändert es auch die Symbole in Nautilus, aber nie die vollständige Sache.

Ich habe versucht, es mit dem Unity-Tweak-Tool, dem dconf-Editor, der Konsole und dem Gnome-Tweak-Tool zu ändern. Ich habe mehrere Neustarts durchgeführt. Nichts hat geklappt. Dann habe ich ein Upgrade auf Xenial Xerus 16.04 durchgeführt und alles noch einmal probiert. Es hat auch nichts geklappt. Jetzt schreibe ich diese Frage.

Ich habe bereits versucht, die Benutzerdatei oder den gesamten Konfigurationsordner zu löschen.

$ compiz --replace

wird erst am Ende ausgeführt und erhält mehrere Fehler. Ich habe in ganz Google gesucht, aber keine Lösung gefunden. Hoffe du kannst mir helfen.

Ich habe ein Lenovo E460 i5 6200u, Intel HD520-Grafik, SSD 256GB, 8GB RAM, wenn das zählt.

3
Nils Höche

Geben Sie in einem Terminal Folgendes ein:

Sudo apt-get remove unity-Tweak-tool && Sudo apt-get install gnome-Tweak-tool

Gehen Sie dann zu etc/gtk-2.0 und etc/gtk-3.0 und löschen Sie die Einstellungsdatei. Starten Sie die Themes neu und ändern Sie sie mit gnome-Tweak-tool.

Es funktioniert gut für mich in Ubuntu 16.04.

2
user593423

Ich habe es geschafft, meine Icon-Themes zum Laufen zu bringen:

  1. Meine Festplatte formatieren und 16.04 neu installieren
  2. Herunterladen meiner Icon-Themes/Themes und manuelle Installation, nicht mit der PPA-Methode (weiß nicht, ob das wichtig ist)
  3. Unity-Tweak-Tool vom SOFTWARE-CENTER aus installieren (!) Funktioniert bei mir nicht, wenn ich es per Terminal installiere.

Zurücksetzen meiner Konfiguration mit

$ dconf reset -f /org/compiz/
$ setsid unity

hat funktioniert, musste aber bei jedem Start eingegeben werden. Es gab auch eine Antwort auf eine ähnliche Frage ( buntu 14.04.1 - Unity Tweak Tool funktioniert nicht? ), die darauf hinwies, dass Sie Ihre Konfiguration zurücksetzen, Unity löschen, aktualisieren und erneut installieren mussten software center, aber das hat bei mir nicht geklappt, ich musste ubuntu neu installieren.

Als Randnotiz: Ich habe auch den Startvorgang so geändert, dass UEFI zuerst gestartet wird, und ich habe das Logical Volume Management bei der Installation deaktiviert, aber ich bezweifle, dass dies Auswirkungen auf diese Lösung hat.

1
Nils Höche

Als ich nach einem Update ein ähnliches Problem auf meinem System entdeckte, kam mir der Verdacht, dass unity-settings-daemon seine Arbeit nicht richtig machte.

Befolgen Sie die Anweisungen von ein weiterer Beitrag auf dem Daemon, den ich neu installiert habe:

Sudo apt-get --reinstall install unity-settings-daemon

und neu gestartet, wodurch das Problem behoben wurde. In deinem Fall einen Versuch wert, denke ich.

0
Marc