it-swarm.com.de

name 'Ops' Python kann nicht importiert werden

Ich versuche, eine Anwendung auszuführen. Ich bekomme jedoch einen Fehler:

from createDB import load_dataset
import numpy as np
import keras
from keras.utils import to_categorical
import matplotlib.pyplot as plt
from sklearn.model_selection import train_test_split
from keras.models import Sequential,Input,Model
from keras.layers import Dense, Dropout, Flatten
from keras.layers import Conv2D, MaxPooling2D
from keras.layers.normalization import BatchNormalization
from keras.layers.advanced_activations import LeakyReLU
#################################################33
#show dataset
X_train,y_train,X_test,y_test = load_dataset()
print('Training data shape : ', X_train.shape, y_train.shape)
print('Testing data shape : ', X_test.shape, y_test.shape)
############################################################
# Find the unique numbers from the train labels
classes = np.unique(y_train)
nClasses = len(classes)
print('Total number of outputs : ', nClasses)
print('Output classes : ', classes)
###################################################
#plt.figure(figsize=[5,5])
#
## Display the first image in training data
#plt.subplot(121)
#plt.imshow(X_train[0,:,:], cmap='gray')
#plt.title("Ground Truth : {}".format(y_train[0]))
#
## Display the first image in testing data
#plt.subplot(122)
########################################################
#X_train.max()
#X_train.shape()
##################################
# normalization and float32
X_train = X_train.astype('float32')
X_test = X_test.astype('float32')
X_train = X_train / 255.
X_test = X_test / 255.
###############################3
#Change the labels from categorical to one-hot encoding
y_train_one_hot = to_categorical(y_train)
y_test_one_hot = to_categorical(y_test)

# Display the change for category label using one-hot encoding
print('Original label:', y_train[25])
print('After conversion to one-hot:', y_train_one_hot[25])
############################################
# training split to trainig and validation
X_train,X_valid,train_label,valid_label = train_test_split(X_train, y_train_one_hot, test_size=0.2, random_state=13)
X_train.shape,
X_valid.shape,
train_label.shape,
valid_label.shape
#########################
batch_size = 64
epochs = 20
num_classes = 3
####################
fashion_model = Sequential()
fashion_model.add(Conv2D(32, kernel_size=(3, 3),activation='linear',input_shape=(28,28,3),padding='same'))
fashion_model.add(LeakyReLU(alpha=0.1))
fashion_model.add(MaxPooling2D((2, 2),padding='same'))
fashion_model.add(Conv2D(64, (3, 3), activation='linear',padding='same'))
fashion_model.add(LeakyReLU(alpha=0.1))
fashion_model.add(MaxPooling2D(pool_size=(2, 2),padding='same'))
fashion_model.add(Conv2D(128, (3, 3), activation='linear',padding='same'))
fashion_model.add(LeakyReLU(alpha=0.1))                  
fashion_model.add(MaxPooling2D(pool_size=(2, 2),padding='same'))
fashion_model.add(Flatten())
fashion_model.add(Dense(128, activation='linear'))
fashion_model.add(LeakyReLU(alpha=0.1))                  
fashion_model.add(Dense(num_classes, activation='softmax'))

Datei "F:\anaconda\install\envs\anaconda35\lib\site-packages\keras\backend\tensorflow_backend.py", Zeile 6 in importieren Sie aus tensorflow.python.framework ops als tf_ops

ImportError: Name 'ops' kann nicht importiert werden

Wie löse ich diesen Fehler?

3
sina tosan

Sie können dies versuchen: 

pip install tensorflow --upgrade
pip install keras --upgrade

Vielleicht überprüft das Keras-Framework, dass Ihre Backend-Version von TensorFlow zu alt ist.

2
Wendong Zheng

Hatte das gleiche Problem und ein Upgrade würde das Problem nicht lösen 

Ich habe es gelöst:

Sudo pip uninstall keras
Sudo pip uninstall tensorflow

Sudo pip install tensorflow
Sudo pip install keras

jetzt funktioniert es gut.

1
Federica Freddi

Versuchen Sie zuerst zu deinstallieren:

pip uninstall tensorflow tensorflow-gpu protocol --yes

pip install tensorflow-gpu==1.9.0

pip install keras==2.2.0
0
Shu Zhang