it-swarm.com.de

Benutzerdienst kann nicht aktiviert werden. "D-Bus-Verbindung konnte nicht hergestellt werden: Verbindung abgelehnt" Support

Ich erhalte diesen Fehler, wenn ich einen systemd-Befehl als Benutzer ausführe:

[email protected]:~ $ systemctl --user list-units
Failed to get D-Bus connection: Connection refused

Ohne den Benutzerparameter läuft der Befehl einwandfrei.

[email protected]:~ $ systemctl list-units
  UNIT                                                                 LOAD   ACTIVE SUB       DESCRIPTION
  proc-sys-fs-binfmt_misc.automount                                    loaded active waiting   Arbitrary Executable File Formats File System Automount Point
  sys-devices-platform-soc-3f201000.serial-tty-ttyAMA0-hci0-rfkill1.device loaded active plugged   /sys/devices/platform/soc/3f201000.serial/tty/ttyAMA0/hci0/rfkil
  sys-devices-platform-soc-3f201000.serial-tty-ttyAMA0-hci0.device     loaded active plugged   /sys/devices/platform/soc/3f201000.serial/tty/ttyAMA0/hci0
  ...
  To show all installed unit files use 'systemctl list-unit-files'.
  lines 102-129/129 (END)

Und Dbus läuft.

[email protected]:~ $ ps -ef | grep dbus
message+   443     1  0 Jan06 ?        00:00:00 /usr/bin/dbus-daemon --system --address=systemd: --nofork --nopidfile --systemd-activation
admin     9082  9040  0 11:42 pts/0    00:00:00 grep --color=auto dbus

Systemd scheint für diesen Benutzer nicht ausgeführt zu werden

[email protected]:~ $ ps -ef | grep systemd
root       142     1  0 Jan06 ?        00:00:08 /lib/systemd/systemd-journald
root       147     1  0 Jan06 ?        00:00:00 /lib/systemd/systemd-udevd
message+   443     1  0 Jan06 ?        00:00:00 /usr/bin/dbus-daemon --system --address=systemd: --nofork --nopidfile --systemd-activation
root       520     1  0 Jan06 ?        00:00:00 /lib/systemd/systemd-logind
admin    10255  9040  0 16:53 pts/0    00:00:00 grep --color=auto systemd

Ich weiß allerdings nicht, wie ich es zum Laufen bringen soll.

Dies scheint auch nicht normal zu sein:

[email protected]:~ $ systemd --test
Trying to run as user instance, but $XDG_RUNTIME_DIR is not set.
11
Folatt

Es sieht so aus, als wäre ein Paket verschwunden:

[email protected]:~ $ Sudo apt-get install libpam-systemd

Und nach einem Neustart funktioniert es wieder.

8
Folatt