it-swarm.com.de

Xcode 8-Shell-Skriptaufruffehler

Ich versuche, dieses Problem stundenlang zu beheben, aber es bleibt bestehen. Ich habe alles in den Foren ausprobiert, nichts hat geholfen. Ich benutze Cocoapods neueste Version 1.2.0.beta.1. Wenn ich versuche, das Projekt zu erstellen, dann bekomme ich Folgendes:  enter image description here

6
sphynx

Ich habe gerade die Beta-Version von Cocoapods gelöscht und die normale Version installiert.

6
sphynx

Für mich (Xcode 9) hat pod install alleine das Problem nicht behoben .

pod deintegrate
pod install

Und der Fehler verschwand.

Möglicherweise möchten Sie auch die abgeleiteten Datenordner für dieses Projekt löschen. Der Speicherort von DerivedData befindet sich in Ihrem Fehlerprotokoll.

8
spijs

Ich habe diesen Fehler behoben. Bitte versuchen Sie es mit unten:

  1. Klicken Sie auf die Hauptprojektdatei.
  2. Gehe zu den Erstellungsphasen.
  3. Klicken Sie auf Skript ausführen und löschen Sie einen beliebigen Pfad darin, damit es nicht versucht, ein Framework zu finden, das von Ihnen gelöscht wurde.

Ich hatte dieses Problem, als ich die Absturzanalyse mit den verschiedenen Frameworks wie "Test Fairy" überprüfte.

Hoffe das klappt. :)

7
saj

Installieren Sie die Pods erneut und führen Sie das Projekt aus. Befehl verwenden:

pod install
7
Ashwin Felix

Bei meiner Lösung wurde mein Computer neu gestartet. Xcode muss in einen fehlerhaften Zustand geraten sein, für den ein Neustart von Xcode nicht ausreichend war. 

2
Jesper

Folgendes habe ich gemacht, als ich das bekam:

  1. Diese Site wurde zum vollständigen Entfernen aller Versionen von Cocoapods verwendet: https://superuser.com/questions/686317/how-to-fully-uninstall-the-cocoapods-von-the-mac-machine
  2. Neu installierte aktuelle stabile Version von Cocoapoden (v1.1.1 für mich) 
  3. Gelöschtes Podlock- und Pod-Verzeichnis 
  4. Alte .xcworkspace-Datei gelöscht (das war für mich der Schlüssel). 
  5. Hat "Pod installieren" 
  6. Xcode geöffnet und Projekt gelöscht und AbgeleiteteDaten gelöscht.
1
elprl

Ich habe gerade meine Pods wieder aktualisiert und es fing an zu arbeiten.

Vielen Dank!

0
janu kansagra

Ich verwende Carthage. Der Grund für diese Fehler war, dass ich die iOS-Zielversion von iOS 10 auf iOS 9 geändert habe. Dieses Problem wurde durch erneutes Ausführen von carthage update behoben. 

0
Bright Future