it-swarm.com.de

Wird .NET Framework 3.5 bei einer SQL Server 2017-Installation noch benötigt, um Database Mail zu verwenden?

Ich vermute, .NET Framework 3.5 wird noch benötigt, um Database Mail mit SQL Server 2017 zu verwenden? Da ich dies vor nicht allzu langer Zeit in meine SQL Server 2016-Installationen auf Server 2016 aufnehmen musste.

Ich konnte überraschenderweise keine endgültige Antwort über das Internet finden, vielleicht bleibt sie unausgesprochen.

5
Eric Swiggum

Nein, es ist für SQL Server 2017 nicht erforderlich. Das Problem mit nicht funktionierender Datenbankmail wurde in 2016 SP1 CU2 und 2016 behoben RTM CU2: FIX: SQL Server 2016 Database Mail) funktioniert nicht auf einem Computer, auf dem .NET Framework 3.5 nicht installiert ist, oder funktioniert nicht mehr, nachdem das SQL Server-Update angewendet wurde

Ich kenne mehrere SQL Server 2016- und 2017-Systeme, die ohne .NET 3.51 installiert sind, und Database Mail funktioniert einwandfrei.

Beachten Sie, dass .NET Framework 3.5 nicht in Hardware- und Softwareanforderungen für die Installation von SQL Server enthalten war und dass die Ansicht von SQL Server 2016 und SQL Server 2017 auf dieser Seite identisch ist. Das Database Mail-Problem wurde in SQL Server 2016 als Fehler angesehen und entsprechend behoben.

7
Tony Hinkle