it-swarm.com.de

Lombok mit Spring Tool Suite 4

Ich habe kürzlich die neue Spring Tool Suite 4 in macOS High Sierra installiert, aber als ich versuchte, die Installation von Lombok auszuführen, wurde meine STS-Installation nicht gefunden.

Ich habe diese Schritte für die manuelle Installation befolgt (Hinzufügen von -javaagent zur INI-Datei), aber ohne Glück: https://www.edvpfau.de/sts-spring-tool-suite-4-mit-lombok/ .

Irgendeine Idee?

7

Ich habe Lombok vor einigen Tagen in Spring Tool Suite 4 Für Mac und Windows installiert. Und keine Probleme.

Eins:

Führen Sie Java -jar lombok.jar Aus.

Hinweis: Normalerweise oder standardmäßig wird das Installationsprogramm nicht gefunden. Dies ist nach meiner Erfahrung das häufigste Szenario.

Zwei:

Drücken Sie die Taste Specify Location.

  • Gehen Sie für Mac in das Verzeichnis Contents in der Datei .app Und suchen Sie die Datei STS.ini.

Hinweis : Daher ist es für jedes Betriebssystem das Ziel, die Datei unique Mit der Erweiterung .ini Zu finden

Normalerweise mache ich das mit geschlossenem IDE).

7
Manuel Jordan

Dies mag zwar zu spät sein, aber es kann für andere hilfreich sein, die dies gerade erleben. Unten ist, wie ich dieses Problem gelöst habe

SCHRITT 1

Suchen Sie lombok in Ihrem Projekt-Maven-Verzeichnis -> Rechtsklick -> Ausführen als -> Java Application enter image description here

SCHRITT 2 Klicken Sie auf die Schaltfläche Standort angeben, um den Pfad auszuwählen, in dem STS installiert ist

(enter image description here

SCHRITT 3 Gehen Sie zu Anwendung/Inhalt/Eclipse/SpringToolSuit4.ini und klicken Sie dann auf Installieren -> Schnellinstallationsprogramm enter image description here

SCHRITT 4 Starten Sie STS neu

0
Prodigy

Um die Antwort von M. Jordan und Prodigy zu ergänzen, erteilen Sie bitte lombok.jar die Ausführungserlaubnis

(Nachdem Sie den oben genannten Schritt ausgeführt haben) Öffnen Sie das Terminal und wechseln Sie in den Inhalt von SpringToolSuite.app

cd /Applications/SpringToolSuite4.app/Contents/Eclipse

Überprüfen Sie dann, ob die Ausführungsberechtigung für lombok.jar verfügbar ist

ls -al

Wenn Sie -rw-r - r-- sehen, müssen Sie die Ausführungsberechtigung erteilen

chmod +x lombok.jar

alternativ könnte man das auch machen

chmod +x /Applications/SpringToolSuite4.app/Contents/Eclipse/lombok.jar

Starten Sie dann STS neu

0
vancleff

am einfachsten ist es, wenn Sie den folgenden Befehl für die Eingabeaufforderung ausführen

Java -jar (jar location/lombok.1.8.1.jar) install (the path where you installed Spring tool suite(STS))

beispielsweise:

Java -jar C:\Users\karthick\.m2\repository\org\projectlombok\lombok\1.18.8\lombok-1.18.8.jar install D:\STS_Tool\spring-tool-suite-4-4.1.2.RELEASE-e4.10.0-win32.win32.x86_64\sts-4.1.2.RELEASE

danach müssen Sie das Tool neu starten.

0
karthick S