it-swarm.com.de

Ist "Mozilla / 4.0 (kompatibel;)" ein gültiger User-Agent?

Ich habe mit User Agent Mozilla/4.0 (kompatibel;) eine zunehmende Anzahl von Anfragen erhalten (derzeit ca. 100 KB pro Tag). Wenn ich einen Benutzeragenten oder verdächtig aussehende Anfragen sehe, recherchiere ich normalerweise (IP-Lookups) und blockiere sie nach Bedarf. Über diesen kann ich mich jedoch nicht entscheiden. Die IPs stammen von Unternehmen wie Bosch und Audi aus Deutschland. Ich habe gelesen, dass einige Proxy-Server (möglicherweise Firmen-Proxys) diesen User-Agent verwenden können. Ich möchte Menschen bei Bosch oder Audi nicht daran hindern, zu meiner Site zu gelangen.

Hat jemand Erfahrung mit diesem User Agent? Kann jemand bestätigen, ob dies tatsächlich ein Firmen-Proxy ist? Oder ist das Spam?

Vielen Dank

3
Effing

Es kann ein gültiger Benutzeragent sein. runlevelsix sagt dies bei ServerFault :

Gemäß mehreren Ressourcen (wie z. B. dieser Eintrag ) handelt es sich um Anforderungen, die von Proxy-Tools verwendet werden, die Vorabrufstrategien verwenden (sie laden alle Seiten herunter, die von der Seite verlinkt sind, die ein Benutzer besucht um sie für den schnellen Abruf zwischenzuspeichern). Blue Coat, Verizon, LookSmart und andere haben sich alle irgendwann herausgestellt, um diesen UserAgent in ihren Tools zu verwenden.

Außerdem haben laut Microsoft einige Versionen von Internet Explorer aus historischen Gründen Variationen des Mozilla/4.0 (kompatiblen) UserAgent verwendet. Siehe hier für weitere Details.

fahadsadah fügt hinzu:

Eigentlich identifizieren sich alle Versionen von Internet Exploder bis IE8 als Mozilla/4.0 (kompatibel), aber normalerweise stehen mehr in den Klammern, wie z. B. die Versionsnummern von Trident/OS. IE9 ist wie alle anderen modernen Browser mit 5.0 kompatibel

1