it-swarm.com.de

pavucontrol bleibt bei "Verbindung zu PulseAudio wird hergestellt. Bitte warten ..." hängen

Ich habe manchmal das Problem, dass ich auf meinem Dell XPS13 mit Ubuntu 16.04 keinen Ton höre. Ich habe ein Logitech G930 angeschlossen. Wenn ich pavucontrol öffne, bleibt es bei "Verbindung zu PulseAudio wird hergestellt. Bitte warten ..." hängen. Ich habe den Ubuntu Audio Problems Guide befolgt (deutsche Version hier: https: // wiki. ubuntuusers.de/Sound_Problembehebung/#Soundsystem ) und fand folgendes:

$ cat /proc/asound/cards
0 [PCH            ]: HDA-Intel - HDA Intel PCH
                     HDA Intel PCH at 0xdc428000 irq 295
1 [H              ]: USB-Audio - Logitech G933 Gaming Wireless H
                     Logitech Logitech G933 Gaming Wireless H at usb->0000:00:14.0-1, full speed

So werden die Soundkarten erkannt. Audio wird jedoch nicht abgespielt:

$ aplay /usr/share/sounds/alsa/Front_Center.wav 
ALSA lib Pulse.c:243:(Pulse_connect) PulseAudio: Unable to connect: Access denied
aplay: main:722: audio open error: Connection refused

Gleiches gilt für Sudo:

$ Sudo aplay /usr/share/sounds/alsa/Front_Center.wav
Home directory not accessible: Permission denied
Home directory not accessible: Permission denied
Playing WAVE '/usr/share/sounds/alsa/Front_Center.wav' : Signed 16 bit >Little Endian, Rate 48000 Hz, Mono

Der Befehl "groups" zeigt NICHT die Audio-Gruppe an, aber was ich merkwürdig finde, ist, dass er die meiste Zeit funktioniert (und oft nach einem Neustart, wenn es Probleme gibt), also würde ich vermuten, dass es nicht das Problem ist.

Wo könnte ich noch suchen?

Bearbeiten:

$ lspci -nnk | grep -A2 Audio
00:1f.3 Audio device [0403]: Intel Corporation Device [8086:9d71]     (rev 
21)
Subsystem: Dell Device [1028:075b]
Kernel driver in use: snd_hda_intel



$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC3246 Analog [ALC3246 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: H [Logitech G933 Gaming Wireless H], device 0: USB Audio     [USB >Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


$ pactl list short sinks
Connection failure: Access denied
11
Bernie

Ich hatte dieses Problem seit dem Upgrade auf 18.04 und habe fast alles gelesen, was es darüber zu lesen gibt. Nach der Installation von PulseEffects habe ich an den Einstellungen, den Paketen herumgespielt und schließlich funktionierte es manchmal, um den richtigen Kanaldurchsatz für das Audio zu erzielen. Aber als ich dann den Audio-Ausgangskanal so änderte, dass Kopfhörer statt Lautsprecher angezeigt wurden, stürzte die Gnom-Shell ab. Dieser Absturz gab mir Einblick in einige "veraltete Pakete", die noch installiert waren und entfernt oder aktualisiert werden mussten.

Zusammenfassend hat das Ausführen dieser Befehle alle meine Audioprobleme nach ein paar Wochen des Debuggens gelöst (so dumm, wenn Sie es jetzt sehen, aber was funktioniert richtig?)

Sudo apt-get update
Sudo apt-get upgrade
Sudo apt-get remove --purge alsa-base pulseaudio
Sudo apt-get install alsa-base pulseaudio pavucontrol
Sudo alsa force-reload
reboot

Dann

Sudo apt-get install pavucontrol
Sudo apt-get install pulseeffects

Nach einem letzten Zurücksetzen des Audioausgangskanals funktionierte es wieder wie ein Zauber.

8
Alex Timmer

Dies löst das gleiche Problem mit meinem:

pulseaudio --check
pulseaudio -D

Entnommen aus: [Gelöst] Herstellen einer Verbindung zu PulseAudio. Bitte warten Sie ... https://classicforum.manjaro.org/index.php?topic=27044.

1