it-swarm.com.de

Knistern / statisch in Discord mit Standard-Audioausgang (PulseAudio)

Ich habe Ubuntu 18.04 vor weniger als einer Woche installiert und 99% von dem, was ich brauche, war kein Problem. Als ich Discord zum ersten Mal installierte, war nach den Anweisungen auf der Website alles in Ordnung. Das Snap-Paket hatte Probleme beim Starten und weigerte sich, die Aktualisierungssequenz zu durchlaufen, als ob es keine Internetverbindung hätte. Wenn ich jedoch nach einem Neustart zum ersten Mal an einem Voice-Chat teilnehme, bekomme ich jedes Mal ein lautes Knistern, wenn jemand spricht. Es behebt sich von selbst, wenn ich den Ausgang meines Kopfhörers von Line Out auf Headphones oder umgekehrt ändere (für mich klingt die Kopfhörereinstellung besser).

Ich dachte anfangs, dass es sich um die Line-Out-Einstellung handelt, und änderte sie mit dies ist eine Anleitung . Das hat es nicht behoben und egal welches ich als Standard festgelegt habe, das Knistern ist in Discord genauso schlimm, bis ich es ändere. Danach klingt jeder Port gut. Ich versuche herauszufinden, wie ich es gut klingen lassen kann, ohne die Einstellung in PulseAudio ändern zu müssen, aber ich bin ratlos.

Alles andere Audio scheint in Ordnung zu sein. Sogar in Spielen wie CSGO gibt es kein Problem mit Voice-Chat, und ich kann andere Spiele spielen, Videos ansehen und Spotify ganz gut anhören. Es scheint nur Zwietracht zu beeinflussen.

Wenn es darauf ankommt, lauten die genauen Einstellungen "Line Out (eingesteckt)" und "Headphones (nicht eingesteckt)", obwohl ich die Kopfhörer trotz des Forums im obigen Link trotzdem als Standard festlegen konnte und sie diesen Port erkennen. Ich verwende die PulseAudio Volume Control (pavucontrol) -App von Ubuntu Software, um diese Einstellungen zu ändern, und das Terminal, um den Standardport festzulegen.

Meine einzigen angeschlossenen Audiogeräte sind Kopfhörer für die Ausgabe, die an den Motherboard-Port angeschlossen sind. Mein Mischpult und meine Kopfhörer sind im Eingang aufgeführt (Kopfhörer Mikrofon stumm geschaltet), beide ebenfalls an das Motherboard angeschlossen. Mixer ist eine USB-Schnittstelle. Meine Webcam wurde an einer Stelle aufgelistet, aber ich bin mir nicht sicher, wo sie hingegangen ist und ob sich dies irgendwie auf die Dinge auswirken kann.

Wenn jemand eine Lösung kennt, lass es mich wissen! Danke

2
Miqued

Ich habe es behoben, indem ich /etc/Pulse/default.pa geändert habe. Suchen und Ersetzen:

load-module module-udev-detect

durch

load-module module-udev-detect tsched=0

Starten Sie dann PulseAudio mit dem folgenden Befehl neu:

pulseaudio -k && Sudo alsa force-reload

6
Jared Chu