it-swarm.com.de

(K) Ubuntu 17.10 - Keine Audiogeräte gefunden, keine Einstellungen, kein Ton

Ich habe gerade Kubuntu 17.10 (neu installiert, ab 17.04) installiert, wobei mein alter /home beibehalten wurde, aber ich habe/neu formatiert, um /boot und /

Als es nach der Installation gestartet wurde, bemerkte ich, dass das Audiosymbol in der Taskleiste "Lautsprecher + rote Linie" ist und keinen Ton anzeigt. Systray Sound Icon> Dropdown sagen:

es wurden keine Ausgabe- oder Eingabegeräte gefunden

muted-icon

In den Einstellungen kann ich nichts in Bezug auf Audio ändern, da das System angibt, dass nichts vorhanden ist. Einstellungen> Multimedia> Lautstärke. Kein Ausgang/Eingabegerät gefunden.

settings1settings2

Seltsamerweise machen Spotify und VLC Geräusche. Aber nicht Firefox, nicht Pillars of Eternity (Steam (Flatpak)). Und in den Einstellungen wird nichts angezeigt. Diese Bilder wurden beim Abspielen von Musik in Spotify aufgenommen.

Wenn ich die Lautstärkeregelung öffne (Menü> Multimedia> PulseAudio-Lautstärkeregelung), wird die folgende Meldung angezeigt:

Verbindung zu PulseAudio fehlgeschlagen. Automatische Wiederholung in 5s. In diesem Fall ist dies wahrscheinlich darauf zurückzuführen, dass Pulse_SERVER in den Eigenschaften von Environment/X11 Root Window oder Default-Server in client.conf falsch konfiguriert ist. Die Situation kann auch auftreten, wenn PulseAudio abgestürzt ist und veraltete Details im X11-Stammfenster hinterlassen hat. Ist dies der Fall, sollte PulseAudio erneut automatisch gestartet werden. Ist dies nicht konfiguriert, sollten Sie start-pulseaudio-x11 manuell ausführen.

Dies war kein Countdown (5s), aber das Fenster blinkte zweimal, um eine Verbindung zu PulseAudio herzustellen. Danach passierte nichts mehr.

Ich habe es mit start-pulseaudio-x11 versucht. Ausgabe:

Connection failure: Connection refused
pa_context_connect() failed: Connection refused

Mein Audiogerät ist über die Standardbuchse (normale Lautsprecher) angeschlossen. Kein HDMI oder so. Zwei Monitore über DP verbunden. Hatte am 17.04. Keine Probleme damit.

Ich habe folgendes ausprobiert: eine alte Frage : mv ~/.Pulse ~/.Pulse_backup

Ergebnis: mv: cannot stat '/home/USER/.Pulse': No such file or directory


TL; DR: Audio funktioniert nach der Installation von Kubuntu 17.10 (/home vom 17.04) nicht mehr. In den Audioeinstellungen sind keine Einstellungen verfügbar. Sound von VLC und Spotify, aber nicht Firefox, Spiel/Steam. Fehlermeldung besagt, dass PulseAudio fehlgeschlagen ist.

12
Edward Alekos

Ich hatte das gleiche Problem und sah die Protokolle in /var/log/syslog. Ich hatte einen Fehler für den pulseaudio-Daemon:

[pulseaudio] module.c: Module "module-switch-on-connect" should be loaded once at most. Refusing to load.

Also habe ich /etc/Pulse/default.pa geöffnet und mit # bearbeitet, um 3 Zeilen zu deaktivieren:

#.ifexists module-switch-on-connect.so
#load-module module-switch-on-connect
#.endif

Vielleicht ist es nicht die beste Lösung, aber es hat meine Probleme gelöst.

9
Carla souza

Ich habe dies durch eine Neuinstallation von pulseaudio gelöst.

Achtung: Wenn Sie benutzerdefinierte Änderungen in/etc/Pulse vorgenommen haben, gehen diese verloren, wenn Sie rm -rf /etc/Pulse wie unten gezeigt ausführen. In meinem Fall gibt es nur eine Hand voll neu installierter Dateien.

pdate 2019: Achten Sie darauf, dass das Paket plasma-desktop deinstalliert wird, während pulseaudio entfernt wird. Installieren Sie es vor dem Booten erneut, da Ihr System sonst möglicherweise nicht ordnungsgemäß bootet.

  • apt-get remove --purge pulseaudio
  • rm -rf /etc/Pulse (möglicherweise auch $ HOME/.config/Pulse entfernen)
  • apt-get install pulseaudio
  • apt-get install plasma-desktop
  • reboot

Dies hat auch einige andere Pakete (wie oss *) deinstalliert, die nicht neu installiert wurden, und in meinem Fall vermisse ich sie überhaupt nicht. ;)

[EDIT]

Wenn Ihre Karte durch etwas wie Sudo aplay -l aufgeführt ist, aber nicht in pavucontrol aufgeführt ist, wird Ihre Karte möglicherweise durch weitere Prozesse gesperrt. Stellen Sie sicher, dass Sudo fuser -v /dev/snd/* keine anderen Prozesse als pulseaudio auflistet. In meinem Fall wurde das Upgrade auf kubuntu 19.04 durch den squeezelite -Prozess blockiert, daher habe ich squeezelite angehalten und deaktiviert und alles war in Ordnung:

$ Sudo fuser -v /dev/snd/*
/dev/snd/controlC0: root  872 F..... squeezelite
/dev/snd/pcmC0D0p:  root  872 F....m squeezelite
[... bad ...]
$ Sudo systemctl disable squeezelite
$ Sudo systemctl stop squeezelite
$ pulseaudio -k
$ Sudo fuser -v /dev/snd/*
/dev/snd/controlC0: myUsername 1459 F..... pulseaudio
[... good ...]
$ pavucontrol

... et voila! Meine Soundkarte ist wieder in pavucontrol verfügbar.

4
ChristophS

Ich hatte genau das gleiche Problem (die gleichen Symptome) und verschwendete Stunden damit, nach einer Lösung zu suchen. Ich habe das Problem behoben, indem ich default.pa bearbeitet habe, um Module statisch zu laden, und hw:1,0 durch hw:0,0 ersetzt habe.

Sudo nano /etc/Pulse/default.pa

Inhalt zu ändern:

load-module module-alsa-sink device=hw:0,0  
load-module module-alsa-source device=hw:0,0  
load-module module-null-sink  
load-module module-pipe-sink  

Speichern und beenden, dann ausführen:

Sudo alsa force-reload  
pulseaudio -k  
start-pulseaudio-x11  

Hoffentlich haben Sie an dieser Stelle Ton.

3
attobot

versuche in .config/zu finden, ob es einen anderen Ordner gibt, der den Puls konfiguriert, in meinem Fall war es die Google-Chrome-Remote-Desktop-App, die ein anderes Profil mit der Pulse-Audio-Konfiguration erstellt hat, das das Laden des normalen Profils verhindert

0
Shmulik Rot

Ich habe es geschafft, den Ton wieder abzurufen, aber die Lautstärkeregelung funktioniert nicht mehr und das Symbol in der Taskleiste wird nicht mehr angezeigt.

Ich habe das pulseaudio und auf die gleiche Weise alsa neu installiert, wie in der Antwort von @ChristophS:

  • apt-get remove --purge pulseaudio
  • rm -rf /etc/Pulse
  • apt-get install pulseaudio
  • reboot

Bearbeitet auch die Zeilen wie in @Carla sousas Antwort:

Also habe ich /etc/Pulse/default.pa geöffnet und mit # bearbeitet, um 3 Zeilen zu deaktivieren:

#.ifexists module-switch-on-connect.so
#load-module module-switch-on-connect
#.endif

Dann ging ich zur Systemkonfiguration wie folgt:

Kubuntu main menu System settings

Danach zum Abschnitt Hardware> Multimedia:

Hardware > Multimedia section in Kubuntu 17.10

Und schließlich habe ich mich für den eingebauten Treiber entschieden:

enter image description here

Wie ich schon sagte, bekam ich den Ton wieder. Aber ich kann es nicht kontrollieren. Irgendeine Idee?

0
Joshua Salazar

@peterlings Antwort hat bei mir funktioniert. Es ist die letzte auf dieser Seite: askubuntu.com/questions/70560/why-am-i-getting-this-connection-to-pulseaudio-failed-error

Er sagte, ich müsse das im Terminal eingeben:

Sudo pulseaudio -k
pulseaudio --start

so sah es auf dem Terminal aus:

[email protected]:~$ Sudo pulseaudio -k
E: [pulseaudio] core-util.c: Home directory not accessible: Permission denied
E: [pulseaudio] main.c: Failed to kill daemon: No such file or directory
[email protected]:~$ pulseaudio --start
N: [pulseaudio] main.c: User-configured server at {2d68ac8ceac9497599efde6fcfca4f8c}unix:/run/user/999/Pulse/native, which appears to be local. Probing deeper

Danach habe ich die Lautstärkeregelung von pulseaudio ausgeführt. Verwenden Sie die normale Verknüpfung, indem Sie in lUbuntu 16.10 darauf klicken. Sie verwenden eine viel neuere Version von KUbuntu.

Ich habe es mit start-pulseaudio-x11 versucht. Ausgabe:

Connection failure: Connection refused
pa_context_connect() failed: Connection refused

"

0
iota

Ich habe nicht genug Repräsentanten, um einen Kommentar abzugeben, aber ich habe das 3. Lösung oben von ChristophS ausprobiert. Dies scheint zwar eine gute Lösung zu sein, aber auf Kubuntu 18.10 mit purge wurden mein Plasma-Desktop und Kubuntu-Desktop deinstalliert. Ich hatte eine Reihe von unnötigen Paketen von einer Wein-Deinstallation aufgelistet, ich plane eine Neuinstallation. Unnötig zu erwähnen, dass dies ziemlich verwirrend war, insbesondere in Verbindung mit den Berechtigungsänderungen, bei denen es sich letztendlich um die rsache handelte, von denen ich dachte, dass sie den Desktop durcheinander brachten.

Die Lektion lautet: Pass auf, was du spülst! Ich denke, es sollte einen Kommentar zu der obigen Lösung geben, um vor der aktuellen Aufnahme von Desktop mit Purge Pulseaudio zu warnen.

apt -s remove --purge pulseaudio
Purg kubuntu-desktop [1.379]
Purg plasma-pa [4:5.13.5-0ubuntu2]
Purg plasma-desktop [4:5.13.5-1ubuntu4]
Purg libcanberra-Pulse [0.30-6ubuntu1]
Purg pavucontrol-qt [0.4.0-1]
Purg pulseaudio-module-bluetooth [1:12.2-0ubuntu4]
Purg pulseaudio [1:12.2-0ubuntu4]

Wenn Hack vom obigen Link funktioniert, könnten die Berechtigungen sein: HOME=/tmp/$USER pulseaudio --start

0
alchemy

Ich habe das gleiche Problem in Kubuntu 17.10. Ich kann nicht sagen, was die Ursache war, es ist passiert, nachdem ich das HDMI-Kabel eingesteckt oder einen Bluetooth-Lautsprecher gekoppelt und den Audio-Ausgangsstrom darauf geändert habe. Nach einigen Suchen habe ich einige Lösungen verwechselt. Audio scheint jetzt zu funktionieren, aber ich frage mich, ob dies eine gute oder schlechte Lösung ist. Was ich getan habe war:

  • Sudo apt-get remove --purge pulseaudio
  • Sudo rm -rf/etc/Pulse
  • Sudo apt-get Pulseaudio installieren
  • Sudo neu starten

Audio war zu hören, aber es gab keine Möglichkeit, es zu kontrollieren. Symbol in der Taskleiste verschwindet. So tat ich:

  • Sudo apt-get Plasma-pa installieren
  • Sudo neu starten

Beim Neustart befand sich das Symbol in der Taskleiste, aber Audio war stumm und funktionierte nicht, genau wie hier . Also habe ich plasma-pa entfernt und kmix installiert. Auf diese Weise funktioniert Audio jetzt.

  • Sudo apt-get entfernen Plasma-pa
  • Sudo apt-get kmix installieren

Ist das eine gute Lösung? Was ist das Problem mit Plasma-PA?

Danke, Luca

0
Luca B

Ich bin auf dasselbe Problem gestoßen. Nach der Installation von pavucontrol habe ich mein System neu gestartet und jetzt werden meine Soundkarte und meine Kopfhörer erkannt.

Sudo apt-get install pavucontrol

Falls pavucontrol nach der Installation Fehler ausgibt, starten Sie Ihr System ne und sie werden verschwinden.

Hoffe das hilft auch anderen.

0
Satish Pandey