it-swarm.com.de

Audio hat ab 12.04 plötzlich aufgehört zu arbeiten

Mein Audio funktioniert in Xubuntu 12.04 nicht mehr, nachdem ich ungefähr ein Jahr lang einwandfrei gearbeitet habe. Dies geschah direkt nach dem Besuch der folgenden Website und der Installation einer Audio-Browser-Anwendung, um Sprachbeispiele für die Erstellung eines Open-Source-Spracherkennungsprogramms hochzuladen: http://www.voxforge.org/home/read

Ich weiß nicht, ob dies das Problem verursacht hat, aber während der Installation dieser Webanwendung funktionierte Audio nicht mehr.

Wenn ich das Terminal eintippe

pulseaudio -D

Ich bekomme folgendes:

E: [pulseaudio] main.c: Daemon startup failed.

Ich habe als nächstes folgendes versucht:

Sudo apt-get purge pulseaudio
Sudo apt-get install pulseaudio

Wenn ich bei der Eingabeaufforderung 'pulseaudio' eingebe, erhalte ich:

E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: pa_pid_file_create() failed.
16
Ben

Das ist mir auch passiert. Ich denke, der Hauptgrund ist, dass der pulseaudio-Daemon nicht richtig getötet wurde.

Führen Sie zuerst pulseaudio --kill und dann pulseaudio --start aus.

Dies hat das Problem für mich behoben.

7
user111874

Es gibt zwei mögliche Korrekturen. Hier sind die beiden Methoden, die ich ausprobiert habe (ich bin nicht sicher, welche der beiden das Problem behoben hat.)

Fix 1

Ich habe einige Kopfhörer angeschlossen und pulseaudio getötet:

pulseaudio --kill

dann habe ich es wieder angefangen:

pulseaudio --start

Dies schien das Problem von nun an zu beheben.

Fix 2

Verwenden Sie stattdessen pavucontrol:

Sudo apt-get install pavucontrol
pavucontrol
4
Sam Mearns

Dies ist ein Update für 13.10.

Ich habe pavucontrol benutzt:

Sudo apt-get install pavucontrol
pavucontrol
2
user205795

Die Schritte, die ein identisches Problem auf meinem Ubuntu 16.04 lösten, waren:

rm -R ~/.config/Pulse   # or rename this folder
Sudo systemctl reboot   # logout and login doesn't do the job
2
pa4080

Das hat bei mir funktioniert

Sudo /usr/bin/amixer set Master toggle

Ich habe alle anderen in diesem Thread vorgeschlagenen Dinge ausprobiert und nichts hat funktioniert.

1
bjarque

Ich habe das gleiche Problem:

E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: pa_pid_file_create() failed.

das Entfernen/Installieren von pulseaudio hat nicht geholfen. Schließlich habe ich herausgefunden, dass mein .Pulse -Verzeichnis in $HOME fehlte. So tat ich:

cd $HOME
mkdir .Pulse
pulseaudio --kill
pulseaudio --start

und startete mein Ubuntu neu. Nachdem es in Ordnung war.

0
ahe_borriglione

Ich habe mein eigenes Problem behoben, indem ich einfach "alsamixer" in die Befehlszeile eingegeben habe und mit einigen Einstellungen gespielt habe, z. B. das Aufheben der Stummschaltung verschiedener Lautstärkeregler für verschiedene Komponenten. Wahrscheinlich hat die Software von voxforge.org einige Lautstärkeregler auf meinem Computer stummgeschaltet und anschließend die Stummschaltung nicht aufgehoben. Vielen Dank für die Hilfe, alle!

Meine Lösung war also:

alsamixer

und deaktivieren Sie verschiedene Lautstärkeregler, bis der Ton wieder kommt. Versuchen Sie auch, mit F6 zwischen Soundkarten zu wechseln. (Es ist hilfreich, ein YouTube-Video im Hintergrund abzuspielen oder Musik auf einer Wiedergabeliste abzuspielen, damit Sie wissen, wann der Ton endlich wieder da ist.)

0
Ben

Sie können versuchen, das .Pulse-Verzeichnis in Ihrem Homefolder zu löschen oder umzubenennen, sich abzumelden und neu anzumelden. Ein neues .Pulse-Verzeichnis wird automatisch von Pulse erstellt, sodass Sie höchstwahrscheinlich eine nützliche Konfiguration erhalten. Das hat mir schon oft geholfen, als ich Probleme mit Pulse hatte.

0
gemue2010