it-swarm.com.de

Wie aktualisiere ich Cabal für Haskell IDE (Leksah) unter Ubuntu 16.04?

Ich möchte Leksah installieren, damit ich lernen kann, wie man in Haskell programmiert. Also habe ich die neuste Version von ghc installiert (hoffe ich richtig). Aber Mir fehlt die neueste Version von Cabal für Leksah. Ich kann es scheinbar nicht installieren. Ich habe Version 1.24, während die neueste Version 1.24 ist. Ich habe Cabal aktualisiert, bevor ich das Folgende durchlief, sowie Version 1.24 heruntergeladen habe. Ich bekomme immer noch die folgenden Antworten. Wenn ich versuche, im Terminal zu installieren, tippe ich Folgendes ein:

cabal install cabal cabal-install

Ich erhalte folgende Antwort:

Resolving dependencies...
cabal: Could not resolve dependencies:
trying: cabal-0.0.0.0 (user goal)
next goal: youProbablyWantCapitalCabal (dependency of cabal-0.0.0.0)
Dependency tree exhaustively searched.

Wenn ich Folgendes tippe:

cabal install foo

Ich erhalte folgende Antwort:

Resolving dependencies...
cabal: Could not resolve dependencies:
trying: foo-1.0 (user goal)
trying: base-4.8.2.0/installed-0d6... (dependency of foo-1.0)
trying: containers-0.5.6.2/installed-593... (dependency of foo-1.0)
next goal: haskell98 (dependency of foo-1.0)
rejecting: haskell98-2.0.0.3 (conflict: base==4.8.2.0/installed-0d6...,
haskell98 => base>=4.7 && <4.8)
rejecting: haskell98-2.0.0.2 (conflict: base==4.8.2.0/installed-0d6...,
haskell98 => base==4.6.*)
rejecting: haskell98-2.0.0.1 (conflict: containers =>
array==0.5.1.0/installed-960..., haskell98 => array>=0.3 && <0.5)
rejecting: haskell98-2.0.0.0 (conflict: containers =>
array==0.5.1.0/installed-960..., haskell98 => array>=0.3 && <0.4)
rejecting: haskell98-1.1.0.1, 1.1.0.0, 1.0.1.1 (conflict:
base==4.8.2.0/installed-0d6..., haskell98 => base>=3 && <4.6)
rejecting: haskell98-1.0.1.0 (conflict: base==4.8.2.0/installed-0d6...,
haskell98 => base<4.6)
rejecting: haskell98-1.0 (conflict: base==4.8.2.0/installed-0d6..., 
haskell98
=> base<4.3)
Dependency tree exhaustively searched.

Ich habe sogar cabal 1.24 heruntergeladen. Das Terminal teilt mir mit, dass ich derzeit Version 1.22.6 installiert habe und Version 1.22.5 der Cabal-Bibliothek verwende.

Wie kann ich Cabal aktualisieren? Sollte ich versuchen, Leksah zu installieren, ohne Cabal zu aktualisieren?

5
A. Bergeron

Diese leicht kryptische Fehlermeldung weist auf Folgendes hin: next goal: youProbablyWantCapitalCabal (dependency of cabal-0.0.0.0)

Das Bibliothekspaket heißt Cabal nicht cabal . Versuchen Sie es mit: cabal install Cabal cabal-install

3