it-swarm.com.de

"Warten auf Installation" für immer - Ubuntu Software - 16.04

Wenn ich versuche, .deb-Dateien mit "Ubuntu Software" zu installieren, wird "Warten auf Installation" für immer fortgesetzt.

37
Vitor Abella

1 - Laden Sie das alte "Ubuntu Software Center" in die neue "Ubuntu Software" herunter.

2 - unity --reset-icons oder Starten Sie Ihren Computer neu (um das "Warten auf die Installation" zu entfernen)

3 - Öffnen Sie die .deb-Datei mit dem gerade installierten "Ubuntu Software Center"

4 - Installieren Sie es

7
Vitor Abella

Installiere .deb Pakete vom Terminal:

$ Sudo dpkg -i <path/to/deb.deb>
$ Sudo apt-get install -f

Die Argumentation hinter apt-get install -f in der Manpage:

 -f, --fix-broken
           Fix; attempt to correct a system with broken dependencies in place. This option, when used with install/remove, can
           omit any packages to permit APT to deduce a likely solution. If packages are specified, these have to completely
           correct the problem. The option is sometimes necessary when running APT for the first time; APT itself does not allow
           broken package dependencies to exist on a system. It is possible that a system's dependency structure can be so
           corrupt as to require manual intervention (which usually means using dpkg --remove to eliminate some of the offending
           packages). Use of this option together with -m may produce an error in some situations. Configuration Item:
           APT::Get::Fix-Broken.

Bildnachweis: Mohit Rajan Kommentar

25
AlexPogue

Nur ein Vorschlag, ich bin mir nicht sicher, ob es helfen sollte, aber wenn Sie häufig Pakete aus .deb-Dateien installieren, ist es ratsam, einen zuverlässigen Paket-Handler wie Gdebi zu verwenden

Wenn Sie jedoch nach Apps suchen und diese vom selben Ort aus installieren möchten, sollten Sie sich an Ubuntu Software Center halten. Um Gnome-Software in den Papierkorb zu werfen und das klassische und vertrauenswürdige Ubuntu Software Center zu installieren, folgen Sie diese Anleitung .

1
ShuaibKunji

Es scheint, dass wir alle von https://bugs.launchpad.net/ubuntu/+source/gnome-software/+bug/1573206 betroffen sind.

Leider gibt es keine andere Lösung als die Verwendung eines anderen Paketmanagers, um diese Pakete zu installieren.

0
thwint