it-swarm.com.de

Ubuntu Server 14.04 Apache 2.4 TLSv1.2 / TLSv1.1-Unterstützung

Kürzlich habe ich meinen Server von Ubuntu Server 12.04 auf Ubuntu Server 14.04 durch eine Neuinstallation von Grund auf aktualisiert.

Es bleibt nur ein Problem. In 12.04 unterstützte Apache 2.2 mit mod_ssl TLS Version 1, 1.1 und 1.2. Nach dem Upgrade auf 14.04 und Apache 2.4 unterstützt Apache nur TLS Version 1, die Unterstützung für 1.1 und 1.2 fehlt.

Ich habe sowohl den Migrationsleitfaden für 2.2 -> 2.4 (keine Änderungen an den mod_ssl-Einstellungen) als auch die Dokumentation von mod_ssl bezüglich der SSLProtocol-Konfigurationsoption befolgt.

Beide

SSLProtocol TLSv1.2 TLSv1.1 TLSv1

und

SSLProtocol TLSv1.2

arbeite nicht. Gibt es eine Möglichkeit, Apache davon zu überzeugen, auch die neuen TLS-Versionen zu unterstützen?

Das Problem scheint jetzt ohne Änderung von meiner Seite gelöst zu sein. Anscheinend wurde libssl zunächst ohne TLSv1.1/TLSv1.2-Unterstützung kompiliert.

3
Jan Henke

Problem hat sich mittlerweile ohne Konfigurationsänderung behoben. Anscheinend wurde libssl in 14.04 zunächst ohne TLSv1.1/TLSv1.2-Unterstützung kompiliert und das wurde inzwischen behoben.

1
Jan Henke