it-swarm.com.de

Welche Firefox-Version ist mit Selenium 2.53.0 kompatibel?

Welche Firefox-Version ist mit Selenium 2.53.0 kompatibel? Ich habe Firefox 45.0 ausprobiert und erhalte folgende Ausnahme:

org.openqa.Selenium.WebDriverException: Failed to connect to binary           
FirefoxBinary(/Applications/Firefox.app/Contents/MacOS/firefox-bin) on   port 7055; process output follows: 
foreignInstall":false,"hasBinaryComponents":false,"strictCompatibility":false,"l   ocales":[],"targetApplications":[{"id":"{ec8030f7-c20a-464f-9b0e-13a3a9e97384}","minVersion":"45.0","maxVersion":"45.*"},{"id":"[email protected]","minVersion":"0","maxVersion":"10"}],"targetPlatforms":[],"multiprocessCompatible":false,"seen":true}
27
user16165

Ich hatte ein ähnliches Problem beim Ausführen von Selenium Webdriver 2.53.0 mit Firefox 47.0.

Selenium Webdriver 2.53.0 funktioniert mit Firefox 46.0. Sie finden die genannte Version unter https://support.mozilla.org/en-US/kb/install-older-version-of-firefox .

35
Jehoshuah

hallo, ich hatte das gleiche Problem, ich hoffe, Sie haben Ihr gelöst, aber vielleicht kann meine Antwort jemand anderem helfen. 

ich fand firefox 26, Selenium 2.48.2 und einen webdriver, die sehr gut zusammenarbeiten. Hier sind die Download-Links:

phpSeleniumWebDrive

Selenium-Server-Standalone-2.48.2

firefox26

0

Sie könnten auch versuchen, Folgendes hinzuzufügen:

System.setProperty("webdriver.firefox.bin","C:\\Users\\AppData\\Local\\Mozilla Firefox\\firefox.exe");
WebDriver driver=new  FirefoxDriver(); 

wenn es auch nicht funktioniert, müssen Sie Ihren FF herunterstufen

0
Sathish kumar