it-swarm.com.de

Warum sagt "Compass Watch", dass sass / script / node (LoadError) nicht geladen werden kann?

Ich habe ein Problem mit meinem Befehl zur Kompassüberwachung - es hat bis vor ein paar Tagen einwandfrei funktioniert. Ich habe keine Änderungen an meinen Konfigurationsdateien vorgenommen.

Ich habe Compass neu installiert und Ruby mit rvm aktualisiert. Ich habe meine custom_require.rb-Datei überprüft, weiß aber nicht, wonach ich suchen soll. Es scheint, als würde versucht, die Datei "sass/script/node" irgendwo zu laden, und aus http://sass-lang.com/docs/yardoc/Sass/Script/Node.html Erfasse ich den Dateipfad - aber ich habe dort nichts.

/Users/sampurcell/.rvm/rubies/Ruby-1.9.3-p194/lib/Ruby/site_Ruby/1.9.1/rubygems/custom_require.rb:60:in `require': cannot load such file -- sass/script/node (LoadError)
  from /Users/sampurcell/.rvm/rubies/Ruby-1.9.3-p194/lib/Ruby/site_Ruby/1.9.1/rubygems/custom_require.rb:60:in `rescue in require'
  from /Users/sampurcell/.rvm/rubies/Ruby-1.9.3-p194/lib/Ruby/site_Ruby/1.9.1/rubygems/custom_require.rb:35:in `require'
  from /Users/sampurcell/.rvm/gems/Ruby-1.9.3-p194/gems/compass-0.12.2/lib/compass/sass_extensions/monkey_patches/browser_support.rb:1:in `<top (required)>'
  from /Users/sampurcell/.rvm/rubies/Ruby-1.9.3-p194/lib/Ruby/site_Ruby/1.9.1/rubygems/custom_require.rb:55:in `require'
  from /Users/sampurcell/.rvm/rubies/Ruby-1.9.3-p194/lib/Ruby/site_Ruby/1.9.1/rubygems/custom_require.rb:55:in `require'
  from /Users/sampurcell/.rvm/gems/Ruby-1.9.3-p194/gems/compass-0.12.2/lib/compass/sass_extensions/monkey_patches.rb:2:in `block in <top (required)>'
  from /Users/sampurcell/.rvm/gems/Ruby-1.9.3-p194/gems/compass-0.12.2/lib/compass/sass_extensions/monkey_patches.rb:1:in `each'
  from /Users/sampurcell/.rvm/gems/Ruby-1.9.3-p194/gems/compass-0.12.2/lib/compass/sass_extensions/monkey_patches.rb:1:in `<top (required)>'
  from /Users/sampurcell/.rvm/rubies/Ruby-1.9.3-p194/lib/Ruby/site_Ruby/1.9.1/rubygems/custom_require.rb:55:in `require'
  from /Users/sampurcell/.rvm/rubies/Ruby-1.9.3-p194/lib/Ruby/site_Ruby/1.9.1/rubygems/custom_require.rb:55:in `require'
  from /Users/sampurcell/.rvm/gems/Ruby-1.9.3-p194/gems/compass-0.12.2/lib/compass/sass_extensions.rb:9:in `<top (required)>'
  from /Users/sampurcell/.rvm/rubies/Ruby-1.9.3-p194/lib/Ruby/site_Ruby/1.9.1/rubygems/custom_require.rb:55:in `require'
  from /Users/sampurcell/.rvm/rubies/Ruby-1.9.3-p194/lib/Ruby/site_Ruby/1.9.1/rubygems/custom_require.rb:55:in `require'
  from /Users/sampurcell/.rvm/gems/Ruby-1.9.3-p194/gems/compass-0.12.2/lib/compass.rb:5:in `block in <top (required)>'
  from /Users/sampurcell/.rvm/gems/Ruby-1.9.3-p194/gems/compass-0.12.2/lib/compass.rb:4:in `each'
  from /Users/sampurcell/.rvm/gems/Ruby-1.9.3-p194/gems/compass-0.12.2/lib/compass.rb:4:in `<top (required)>'
  from /Users/sampurcell/.rvm/rubies/Ruby-1.9.3-p194/lib/Ruby/site_Ruby/1.9.1/rubygems/custom_require.rb:55:in `require'
  from /Users/sampurcell/.rvm/rubies/Ruby-1.9.3-p194/lib/Ruby/site_Ruby/1.9.1/rubygems/custom_require.rb:55:in `require'
  from /Users/sampurcell/.rvm/gems/Ruby-1.9.3-p194/gems/compass-0.12.2/bin/compass:20:in `block in <top (required)>'
  from /Users/sampurcell/.rvm/gems/Ruby-1.9.3-p194/gems/compass-0.12.2/bin/compass:8:in `fallback_load_path'
  from /Users/sampurcell/.rvm/gems/Ruby-1.9.3-p194/gems/compass-0.12.2/bin/compass:19:in `<top (required)>'
  from /Users/sampurcell/.rvm/gems/Ruby-1.9.3-p194/bin/compass:19:in `load'
  from /Users/sampurcell/.rvm/gems/Ruby-1.9.3-p194/bin/compass:19:in `<main>'
  from /Users/sampurcell/.rvm/gems/Ruby-1.9.3-p194/bin/Ruby_noexec_wrapper:14:in `eval'
  from /Users/sampurcell/.rvm/gems/Ruby-1.9.3-p194/bin/Ruby_noexec_wrapper:14:in `<main>'

Hat jemand irgendwelche Ideen?

70
Sam Purcell

Deinstallieren Sie sass und installieren Sie es erneut mit den folgenden Schritten:

gem uninstall sass
gem install sass

Bei der Installation von sass ist ein Problem aufgetreten, das behoben wurde.

112
Mike Grace

In meinem Fall war die Sass-Version nicht mit Compass kompatibel.

FIX:

  1. deinstallieren Sie Sass AND Compass

    gem uninstall compass
    gem uninstall sass
    
  2. installiere Compass wer installiert automatisch eine kompatible Sass Engine

    gem install compass
    
24
Nicolas Janel

Diese Kombination funktioniert endlich für mich, um Compass und SASS Sourcemaps zusammenzubringen:

Gemfile

gem 'sass', '3.3.0.alpha.149'
gem 'compass', '0.12.2'
gem 'compass-sourcemaps', "~> 0.12.2.sourcemaps.57a186c"

Kompass config.rb

sass_options = {:sourcemap => true}
13
Volker Rose

Diese spezielle Version funktioniert gut auf beiden:

gem 'sass', '3.3.0.alpha.149'
gem 'compass', '0.12.2'

Sie sind möglicherweise nicht miteinander kompatibel. Aus diesem Grund werden diese Fehler angezeigt (wenn Sie eine Version von Bleeding Edge verwenden).

10
Jürgen Paul

Wenn Sie Ubuntu verwenden, kann es ein Problem mit der Kollision von apt-get und rvm geben.

Versuchen Sie, rvm mit rvm implode Zu entfernen, und führen Sie dann aus

Sudo apt-get install Ruby-compass 

compass watch Hat danach für mich gearbeitet.

4
raam86

Eine Variation der obigen Antworten: Für mich (mit Bootstrap für Sass), stellte sich heraus, dass

gem install bootstrap-sass

das wurde benötigt, um dieses Problem zu beheben. Für mich begann das LoadError-Problem mit Compass, nachdem ich die von mir verwendete Version von Ruby) aktualisiert hatte.

3
Nick F

Ich glaube, das liegt an Versionskonflikten mit sass.

https://rubygems.org/gems/compass gem ist derzeit bei v0.12.16 currently - füge dies zu Gemfile hinzu

gem 'sass', '3.2.19'
gem 'compass', '0.12.6'

Möglicherweise müssen Sie zuerst alle Versionen beider Gems deinstallieren.

3
lfender6445

Ich konnte es auf diese Weise beheben

gem uninstall sass
gem install sass -v 3.2.12

Dies ist definitiv auf ein Versionsabhängigkeitsproblem zurückzuführen. Sie sollten Ihre Grunt-Aufgabe besser reparieren, damit sie mit den neueren Versionen von saas, compass usw. kompatibel ist.

2
ice.nicer

Ich hatte das gleiche Problem und stellte dann fest, dass ich zwei Kompassversionen hatte:

compass watch oder compass compile

Der Compiler wusste nicht, welche Kompassversion er zum Kompilieren verwenden sollte. Sie können also explizit angeben, mit welcher Kompassversion Sie arbeiten möchten:

compass _1.0.3_ watch

Es gibt noch einen weiteren interessanten Thread .

1
Sérgio

Die folgenden Kombinationen haben bei mir funktioniert:

gem install compass --pre
gem install sass -v 3.3.3
0
ATSiem

Ich musste eine Gemdatei mit den richtigen Versionen einrichten (dieser Fehler wird für mich durch nicht übereinstimmende SASS- und Compass-Versionen verursacht). Ich habe das Folgende mit bundle install um das Problem zu lösen:

source "https://rubygems.org"

gem 'bootstrap-sass', "~> 3.2.0"
gem 'sass', [ "< 3.5" , ">= 3.3.13" ]
gem 'compass', "~> 1.0.1"
gem 'compass-core', "~> 1.0.1"
gem 'compass-import-once', "~> 1.0.5"
gem 'chunky_png', "~> 1.2"
gem 'rb-fsevent', ">= 0.9.3"
gem 'rb-inotify', ">= 0.9"
0
Nick