it-swarm.com.de

R - kann nicht auf URLs für die Paketinstallation zugreifen

Ich habe kürzlich R Studio (Version 0.99.892) auf einem PC (Windows 8) installiert und versuche, unter anderem die folgenden Pakete zu installieren: ggplot2; dplyr; rmarkdown; tidyr.

Weder R noch R Studio können eines dieser Pakete installieren. Jedes Mal, wenn ich versuche, ein Paket zu installieren, erhalte ich die Warnungen, die ich am Ende dieses Beitrags anführe.

Ich habe den Befehl install.packages sowie das integrierte Paketinstallationstool verwendet. Ich habe verschiedene Spiegel ausprobiert.

Ich habe eine öffentliche Internetquelle der Universität ausprobiert, meine eigene private Internetquelle und eine Telefonleitung. Ich habe versucht, eine Verbindung über ein VPN herzustellen. Ich habe R Studio zu meiner Windows-Firewall-Ausnahmeliste hinzugefügt und die Windows-Firewall vollständig deaktiviert. Ich verwende keine anderen Firewalls.

Ich habe die verschiedenen Verbindungsoptionen auf der Registerkarte "Pakete" in den globalen Optionen umgeschaltet.

Ich kann in einem Browser auf die URLs zugreifen.

Hier sind die Warnungen von R Studio:

> install.packages("devtools")
Warning in install.packages :
  InternetOpenUrl failed: 'The server name or address could not be resolved'
Warning in install.packages :
  InternetOpenUrl failed: 'The server name or address could not be resolved'
Warning in install.packages :
  unable to access index for repository https://cran.fhcrc.org/src/contrib:
  cannot open URL 'https://cran.fhcrc.org/src/contrib/PACKAGES'
Warning in install.packages :
  InternetOpenUrl failed: 'The server name or address could not be resolved'
Warning in install.packages :
  InternetOpenUrl failed: 'The server name or address could not be     resolved'
Warning in install.packages :
  unable to access index for repository http://www.stats.ox.ac.uk/pub/RWin/src/contrib:
  cannot open URL 'http://www.stats.ox.ac.uk/pub/RWin/src/contrib/PACKAGES'
Installing package into ‘C:/Users/Nikhailovich/Documents/R/win-library/3.2’
(as ‘lib’ is unspecified)
Warning in install.packages :
  InternetOpenUrl failed: 'The server name or address could not be resolved'
Warning in install.packages :
  InternetOpenUrl failed: 'The server name or address could not be resolved'
Warning in install.packages :
  unable to access index for repository https://cran.fhcrc.org/src/contrib:
  cannot open URL 'https://cran.fhcrc.org/src/contrib/PACKAGES'
Warning in install.packages :
  InternetOpenUrl failed: 'The server name or address could not be resolved'
Warning in install.packages :
  InternetOpenUrl failed: 'The server name or address could not be resolved'
Warning in install.packages :
  unable to access index for repository http://www.stats.ox.ac.uk/pub/RWin/src/contrib:
  cannot open URL 'http://www.stats.ox.ac.uk/pub/RWin/src/contrib/PACKAGES'
Warning in install.packages :
  package ‘devtools’ is not available (for R version 3.2.3)
Warning in install.packages :
  InternetOpenUrl failed: 'The server name or address could not be resolved'
Warning in install.packages :
  InternetOpenUrl failed: 'The server name or address could not be resolved'
Warning in install.packages :
  unable to access index for repository https://cran.fhcrc.org/bin/windows/contrib/3.2:
  cannot open URL 'https://cran.fhcrc.org/bin/windows/contrib/3.2/PACKAGES'
Warning in install.packages :
  InternetOpenUrl failed: 'The server name or address could not be resolved'
Warning in install.packages :
  InternetOpenUrl failed: 'The server name or address could not be resolved'
Warning in install.packages :
  unable to access index for repository http://www.stats.ox.ac.uk/pub/RWin/bin/windows/contrib/3.2:
  cannot open URL 'http://www.stats.ox.ac.uk/pub/RWin/bin/windows/contrib/3.2/PACKAGES'

Hier sind die Warnungen aus R (3.2.3):

> install.packages("ggplot2")
Installing package into ‘C:/Users/Nikhailovich/Documents/R/win-library/3.2’
(as ‘lib’ is unspecified)
--- Please select a CRAN mirror for use in this session ---
Error in download.file(url, destfile = f, quiet = TRUE) : 
  cannot open URL 'https://cran.r-project.org/CRAN_mirrors.csv'
In addition: Warning message:
In download.file(url, destfile = f, quiet = TRUE) :
  InternetOpenUrl failed: 'The server name or address could not be resolved'
Warning: unable to access index for repository https://dirichlet.mat.puc.cl/src/contrib:
  cannot open URL 'https://dirichlet.mat.puc.cl/src/contrib/PACKAGES'
Warning: unable to access index for repository http://www.stats.ox.ac.uk/pub/RWin/src/contrib:
  cannot open URL 'http://www.stats.ox.ac.uk/pub/RWin/src/contrib/PACKAGES'
Warning: unable to access index for repository https://dirichlet.mat.puc.cl/bin/windows/contrib/3.2:
  cannot open URL 'https://dirichlet.mat.puc.cl/bin/windows/contrib/3.2/PACKAGES'
Warning: unable to access index for repository http://www.stats.ox.ac.uk/pub/RWin/bin/windows/contrib/3.2:
  cannot open URL 'http://www.stats.ox.ac.uk/pub/RWin/bin/windows/contrib/3.2/PACKAGES'
Warning message:
package ‘ggplot2’ is not available (for R version 3.2.3) 

In R und R Studio gibt es mehrere Stapelaustausch-Posts zur Paketinstallation, aber ich konnte keine finden, die meine spezielle Situation beantworteten. Vielen Dank im Voraus an alle, die wissen, was los ist

5
N. Engel

Führen Sie diesen Befehl aus:

options(repos="https://CRAN.R-project.org")

versuchen Sie danach, install.packages zu installieren. Es sollte funktionieren. Auf meinem System getestet.

3
Awinash Singh

Das ist mir schon mal passiert. Versuchen Sie, den Speicherort explizit anzugeben:

install.packages("devtools", repos="https://cran.rstudio.com/")
2
Markus

Sie können zwar den Speicherort angeben, wenn Sie die Funktion install.packages() mit dem Argument repos= verwenden, aber Sie können auch Ihr Lieblingsrepository auswählen, das bei jedem Herunterladen eines Pakets verwendet wird.

    options(repos="my_favorite_CRAN_mirror")

Eine Liste aller verfügbaren Mirrors finden Sie auf der CRAN-Website . Kopieren Sie die Adresse des nächstgelegenen CRAN-Repositorys, und fügen Sie sie ein.

Nach diesem Schritt sollten Sie in der Lage sein, install.packages('ggplot2') erneut zu versuchen.

2
bobolafrite

Sie sollten folgenden Code versuchen:

install.packages("ggbiplot",dependencies = TRUE, repos = 'http://cran.rstudio.com/')

Es wird Ihnen helfen, die Pakete für den Fehler zu installieren:

paket ist für diese Version nicht verfügbar

1
user10451153

Beim Versuch, die Pakete dplyr, tidyr zu installieren, ist ein ähnlicher Fehler aufgetreten. Ich habe das Problem behoben, indem ich meinen R.version überprüft und eine neue Version von Base R heruntergeladen habe. (3.3.3)