it-swarm.com.de

Fehler beim Installieren des RGL-Pakets

Ich habe diese Frage hier gesehen: Fehler beim Laden des rgl-Pakets mit Mac OS X , aber es werden keine Installationsfehler erwähnt, was in meinem Fall der Fall ist. Ich kann kein rgl-Paket mit diesem Befehl in R installieren:

source("http://bioconductor.org/biocLite.R")
biocLite("rgl")

Der folgende Fehler wird angezeigt:

configure: error: X11 not found but required, configure aborted.
ERROR: configuration failed for package ‘rgl’
* removing ‘/Library/Frameworks/R.framework/Versions/3.2/Resources/library/rgl’

Ich habe diese Adresse /Library/Frameworks/R.framework/Versions/3.2/Resources/library geprüft und es gibt keinen rgl-Ordner. Daher kann ich aglrgl.so (oder rgl.so) nicht löschen. Dies ist die Antwort auf die oben genannte Frage. Können Sie mir bitte bei diesem Installationsproblem helfen? Vielen Dank.

35
Matin Kh

Alle erwähnten Antworten sind korrekt. Keiner ist jedoch für Mac.

In meinem Fall (ich bin ein Mac-Benutzer) habe ich das Problem durch Installieren von XQuartz gelöst und R. neu gestartet.

11
Matin Kh

Bei einer sauberen 16.04-Ubuntu-Installation (und anscheinend für 18.04 gemäß den folgenden Anweisungen) wird dieses Problem möglicherweise angezeigt, wenn Sie versuchen, rgl von CRAN zu installieren:

prüfung auf X ... keine Konfiguration: Fehler: X11 nicht gefunden, aber erforderlich, Konfiguration abgebrochen.

FEHLER: Konfiguration für Paket 'rgl' fehlgeschlagen

Dank an diesen Blog, der meine Probleme bei der Installation von rgl gelöst hat:

http://solaimurugan.blogspot.ca/2015/09/3d-data-visualization-using-r-configure.html

Falls der Link oben verschwindet, lautet die im Blog beschriebene Lösung:

Sudo apt-get install xorg 
Sudo apt-get install libx11-dev 
Sudo apt-get install libglu1-mesa-dev 

In jüngerer Zeit erfordert die Installation von rgl auf einer neuen ubuntu 16.04-Installation auch einen weiteren Schritt (wie in den Kommentaren unten angegeben), wenn Sie diesen Fehler erhalten:

schwerwiegender Fehler: ft2build.h: Keine solche Datei oder Verzeichnis

Dies wird gelöst mit:

Sudo apt-get install libfreetype6-dev

Dann sollte rgl von CRAN installiert werden.

34
FXQuantTrader

Unter Ubuntu funktionierte für mich die Installation des Pakets direkt von der Befehlszeile aus:

Sudo apt-get install r-cran-rgl

(Wir haben hier ein seltsames Setup, also YMMV)

29
Tony Bruguier

Unter CentOS wurde schließlich libpng-dev installiert:

Sudo yum install libpng-devel.x86_64

Vorher habe ich xorg, libx11, die mesa GL -Bibliothek und freeglut installiert.

Sudo yum install xorg-x11-server-Xvfb.x86_64 xorg-x11-server-devel.x86_64 
Sudo yum install libX11.x86_64 libX11-devel.x86_64
Sudo yum install mesa-libGL mesa-libGL-devel mesa-libGLU mesa-libGLU-devel
Sudo yum install freeglut.x86_64 freeglut-devel.x86_64

Ich fand schließlich heraus, was fehlte, indem ich versuche, aus dem Quellcode zu kompilieren (lade die tar.gz unter cran ) und die config.log nach ./configure zu prüfen, schlug fehl.

10
Victor Kostyuk

Ich bin nicht sicher über den Mac-Fall, aber unter Windows hatte ich Probleme beim Herunterladen desselben Pakets. Zur Installation der RGL ist das Paket devtools erforderlich

install.packages("devtools")
library(devtools)
install.packages("rgl")
library(rgl)
4

Ich habe lange gebraucht, um das auf dem [RHEL 3.10.0-862.14.4.el7.x86_64 x86_64 x86_64 x86_64 GNU/Linux] herauszufinden. Folgende Pakete sind erforderlich:

libpng12-devel.x86_64
ImageMagick-c++-devel.x86_64
mesa-libGLU-devel.x86_64
libselinux-devel.x86_64
xorg-x11-apps
0
Cloud

Bei OpenSuse

Sudo zypper install xorg-x11-devel
Sudo zypper install glu-devel
0
Bryce Frank