it-swarm.com.de

wie installiere ich Python-Devel für Version 2.6?

ich benutze Centos 5.4, die Standard-Python-Version ist Python2.4, also benutze ich Python2.6.2.tar.gz, um eine Python 2.6-Version zu kompilieren

und jetzt möchte ich das Board Review-Projekt installieren, es muss das Python-Devel-Paket installieren. Wenn ich yum install python-devel verwende, wird die für Python2.4 relevante Version installiert.

wie kann ich ein Python2.6-Versionsentwicklungspaket installieren?

11
maolingzhi

Wenn Sie EPEL repo aktivieren, können Sie Python 2.6 und die Entwickler-Header mit yum installieren:

# yum install python26
# yum install python26-devel

Diese Pakete stehen dann nicht in Konflikt mit den Python 2.4-Paketen.

12
wrgrs

Sieht so aus, als wäre es mehr Systemadministration als nötig. Hier sind einige hilfreiche Hinweise:

  1. http://blog.milford.io/2010/08/new-method-for-installing-python-2-6-4-with-mysql-python-on-centos-5-5/
  2. Wie installiere ich das Paket python2.6-devel unter CentOs 5

Wenn Sie jedoch nur die Reviewboard-Software installieren, können Sie das Paket unter http://www.python.org herunterladen, eine ./configure-Datei erstellen und altinstall auf eine lokale Version ausführen und dann auf diesen Interpreter verweisen in die setup.py-Datei Ihres Reviewboard-Downloads.

0
Senthil Kumaran