it-swarm.com.de

Welches Eclipse-Paket sollte ich für PyDev herunterladen?

Welches Eclipse-Paket soll ich für Python Entwicklung mit PyDev wählen?

Nichts auf der Eclipse-Homepage sagt mir, was ich wählen soll, und die PyDev-Dokumentation geht davon aus, dass ich Eclipse bereits installiert habe. Ist es wichtig, welches Eclipse-Paket ich wähle?

62

Wenn Sie nur Python dev ausführen möchten, würde ich einfach Platform Runtime Binary verwenden.

Danach folge ich den Anweisungen http://pydev.org/download.html und http://pydev.org/manual_101_root.html , um PyDev zu installieren.

Ich verwende das gleiche Setup für die Python Entwicklung. Ich habe auch das RadRails-Plugin für die Ruby on Rails Entwicklung.

30
Owen

PyDev wurde von Aptana erworben.

4
Luke

Angenommen, Python und nichts anderes - ich würde nur die "Runtime Binary" -Edition von Eclipse erhalten und die PyDev -Erweiterung hinzufügen. Auf diese Weise startet Eclipse blitzschnell, verbraucht weniger Speicher und behindert Sie im Allgemeinen weniger. Darüber hinaus können Sie jederzeit beliebige Erweiterungen/Plugins hinzufügen, die Sie benötigen. Die Laufzeit beträgt im Allgemeinen etwa 50 MB, anstatt der üblichen 100+ für das SDK oder andere Versionen.

Die neueste Version finden Sie immer hier:

http://download.Eclipse.org/Eclipse/downloads/

Zum Zeitpunkt dieses Postings wäre das 3.6.1:

http://download.Eclipse.org/Eclipse/downloads/drops/R-3.6.1-201009090800/index.php#PlatformRuntime

4
Goyuix

Wenn Sie anfangen wollen, empfehle ich Ihnen python easyeclipse .

Pydev kann einige Inkompatibilitäten verursachen, wenn es zusammen mit anderen Erweiterungen verwendet wird.

2
David Arcos

Eine nützliche Verknüpfung ist das Herunterladen von EasyEclipse für PyDev . Dies ist eine Version von Eclipse, die bereits für pydev vorkonfiguriert ist und einfacher zu installieren scheint, als alle Eclipse-Teile selbst zu sammeln. Leider wird eine ziemlich alte Version von PyDev verwendet, aber dies kann leicht behoben werden, indem Sie zu Help > Software Updates > und Eclipse die neueste Version holen lassen (Sie müssen vorher den PyDev-Speicherort in SourceForge ändern).

2
J. Peterson

Ich bevorzuge, dass Sie Luna verwenden, ein Tool für Java Entwickler, die Java EE- und Webanwendungen erstellen. Sicher können Sie PyDev hinzufügen dazu.

Wenn Sie mit Python, Eclipse und pydev beginnen, müssen Sie wahrscheinlich Schritt für Schritt vorgehen.

Befolgen Sie entweder diese einfachen Schritte oder sehen Sie sich dieses Video an .

Schritt 1: Eclipse (Luna) herunterladen und installieren

Schritt 2: Eclipse öffnen >> Hilfe >> Neue Software installieren ...

Schritt 3: Geben Sie im Textfeld 'Arbeiten mit' Folgendes ein: http: //pydev.org/updates

Schritt 4: Markieren Sie das Kontrollkästchen PyDev >> weiter >> weiter >> beenden

Schritt 5: Es wird installiert, aber später wird ein neuer Frame geöffnet. Aktivieren Sie "Brainwy Software, PyDev, Brainwy >> OK"

Eclipse wird neu gestartet, nachdem Sie auf OK geklickt haben.

Schritt 6: Klicken Sie auf Datei >> Neu >> Projekt >> PyDev-Projekt >>

Jetzt müssen Sie Interpreter hinzufügen.

Schritt 7: Klicken Sie auf "Bitte konfigurieren Sie einen Interpreter, bevor Sie fortfahren"

Schritt 8: Klicken Sie auf "Manual Config"

Schritt 9: Klicken Sie auf "Neu" und geben Sie den Namen des Interpreters (Python 2.xx oder python 3.xx die von Ihnen verwendete Version) oder einen anderen Namen ein wie es Dir gefällt.

Schritt 10: Klicken Sie auf "Durchsuchen", um den Pfad anzugeben.

Wenn Sie Windows verwenden, befindet es sich wahrscheinlich in Laufwerk C :.

Wenn Sie Ubuntu verwenden, befindet es sich in "/usr/bin/python2.x" oder verwenden Sie den Befehl "whereis python" im Terminal.

Schritt 11: Danach wählen Sie den Interpreter >> Fertig.

Und du bist gut zu gehen.

2
kiok46

Ich würde http://www.liclipse.com/ empfehlen, wenn Sie eine einfache und unkomplizierte Einrichtung wünschen (insbesondere für die Webentwicklung, da es auch Editoren für webbezogene Inhalte wie HTML gibt, CSS, Javascript) oder nur die Platform Runtime Binary (die leichteste veröffentlichte Eclipse mit den für Pydev benötigten Dingen, ca. 47 MB) erhalten Sie unter: http://download.Eclipse.org/Eclipse/downloads / , wählen Sie die gewünschte Version aus und suchen Sie dann nach der Platform Runtime Binary).

Die Installationsanweisungen finden Sie unter: http://pydev.org/manual_101_install.html (und von dort folgt ein Handbuch für die ersten Schritte).

1
Fabio Zadrozny

Normalerweise erwähnt niemand etwas anderes als Eclipse unterstützt Python in seinem DLTK-Plug-in-Set (Dynamic Languages ​​Toolkit). Vielleicht möchten Sie es ausprobieren.

Wie auch immer, es ist nicht so funktionsfähig wie das PyDev Plugin, Sie können es also sicher haben. PyDev fordert Sie auf, das Zertifikat zu akzeptieren, das für MIM-Angriffe anfällig ist.

Vielleicht möchten Sie PyCharm IDE in Betracht ziehen, da es auch PyDev-Arbeit hat eingeschlossen . Das PyCharm-Team hat eine eigene PyDev-Filiale und hatte einige Arbeiten an seinem Debugger. Einige Details daz Zusammenarbeit.

0
Sergei

pydev und Python2.6 funktionieren nicht mit Eclipse für C++. Laden Sie die klassische Version herunter und Sie sollten gut sein.

0
Viky

Ich denke, dass die Aptana-Distribution von Eclipse heutzutage der einfachste Weg ist, PyDev zu bekommen ... zumal es jetzt für die Vollversion kostenlos ist. Wenn Sie das Studio von hier herunterladen: http://www.aptana.org/ Sie können PyDev einfach über den Plug-in-Manager installieren, sobald es ausgeführt wird.

0
Tim White