it-swarm.com.de

Runpy-Modul konnte nicht importiert werden

Ich versuche, ein Python-Modul auf einem Raspberry Pi zu installieren, auf dem Linux ausgeführt wird. Ich benutze Python 2.7.11 und habe folgende Befehle ausprobiert:

python -m pip install schedule 

python -m easy_install schedule

python2.7 -m pip install schedule

In jedem Fall erhalte ich dieselbe Fehlermeldung:

Could not import runpy module

Ich bekomme dieselbe Fehlermeldung, egal welches Modul ich installiere. Was könnte dieses Problem verursachen? Ich konnte bei Google-Suchen, die ich in der Fehlermeldung durchgeführt habe, nichts Nützliches finden.

BEARBEITEN: 

Wenn ich versuche, Sudo zu einem der folgenden Befehle hinzuzufügen:

Sudo python -m pip install schedule oder Sudo /usr/bin/python -m pip install schedule

Ich bekomme den Fehler:

-sh: Sudo: not found

EDIT2:

Wenn ich python -m pip install runpy versuche, bekomme ich immer noch:

Could not import runpy module
3
Gerald Murphy

Das Runpy-Modul wird standardmäßig während der Installation der Umgebung installiert.

Es kann also ein Problem mit der Installation der virtuellen Umgebung geben. Dies geschieht, wenn die Installation zwischenzeitlich abgebrochen wurde oder eine alte Umgebung nicht ordnungsgemäß entfernt und überschrieben wurde.

Versuchen Sie also, die Umgebung erneut zu installieren.

1
Tushar Rajdev

Ich bin auf den gleichen Fehler gestoßen und hoffe, dass meine eigene Erfahrung etwas helfen wird. Überprüfen Sie zunächst Ihren PYTHONPATH (echo $ PYTHONPATH), um zu sehen, ob er leer ist. Normalerweise sollte es leer sein. Ist dies nicht der Fall, müssen Sie den entsprechenden Python-Bibliothekspfad explizit angeben.

In meiner eigenen Umgebung lautet die falsche Konfiguration:

export PYTHONPATH=/mnt/usb/srv/homeassistant/lib/python3.4/site-packages

und mein Python-Standort ist:

/usr/bin/python

Also füge ich den Bibliothekspfad meines Pythons der Konfiguration hinzu (vergessen Sie nicht das ':'):

export PYTHONPATH=/mnt/usb/srv/homeassistant/lib/python3.4/site-packages:/usr/lib/python3.6/site-packages:/usr/lib/python3.6/site-packages

Der Fehler ist behoben.

1
user2760751