it-swarm.com.de

Fehler bei der Installation von Pillow (Python-Modul) unter Linux

Ich versuche Pillow (Python-Modul) mit pip zu installieren, aber es gibt folgenden Fehler aus:

ValueError: jpeg is required unless explicitly disabled using --disable-jpeg, aborting

Also, wie der Fehler sagt, habe ich versucht:

pip install pillow --global-option="--disable-jpeg"

Aber es schlägt fehl mit:

error: option --disable-jpeg not recognized

Irgendwelche Hinweise, wie man damit umgeht?

154
mchfrnc

Danke @mfitzp. In meinem Fall (CentOS) sind diese Bibliotheken im yum repo nicht verfügbar, aber tatsächlich war die Lösung noch einfacher. Was ich getan habe:

Sudo yum install python-devel
Sudo yum install zlib-devel
Sudo yum install libjpeg-turbo-devel

Und jetzt ist die Installation des Kissens erfolgreich abgeschlossen.

33
mchfrnc

Es wurde ein Fehler für Pillow hier gemeldet, der darauf hinweist, dass libjpeg und zlib jetzt erforderlich sind ab Kissen 3.0.0.

Die Installationsanweisungen für Pillow unter Linux enthalten Hinweise zur Installation dieser Pakete. Beachten Sie, dass möglicherweise nicht alle der folgenden Pakete auf Ihrem Computer fehlen (Kommentare deuten darauf hin, dass nur libjpeg8-dev fehlt tatsächlich).

pip/PyPi (Kissen> 3.4.2)

Die neuesten Versionen von Pillow sind auf PyPi als Räder erhältlich - der neue Standard-Packungsmechanismus für Python. Diese vorgefertigten Pakete enthalten alle erforderlichen binären Abhängigkeiten, damit Pillow ausgeführt werden kann, und sollten verwendet werden, wenn Sie Pillow mit PyPi installieren möchten

Um Räder verwenden zu können, benötigen Sie eine Version von pip>=1.4. Wenn Sie eine frühere Version verwenden (pip --version) aktualisiere pip wie folgt:

pip install --upgrade pip 

Sobald pip aktualisiert wurde, pip install verwendet standardmäßig plattformspezifische Raddateien, sofern diese verfügbar sind. Verwenden Sie den folgenden Befehl, um Pillow auf die neueste Version von PyPi zu aktualisieren:

pip install --upgrade pillow

Ubuntu 12.04 LTS oder Raspian Wheezy 7.0

Sudo apt-get install libtiff4-dev libjpeg8-dev zlib1g-dev libfreetype6-dev liblcms2-dev libwebp-dev tcl8.5-dev tk8.5-dev python-tk

Ubuntu 14.04

Sudo apt-get install libtiff5-dev libjpeg8-dev zlib1g-dev libfreetype6-dev liblcms2-dev libwebp-dev tcl8.6-dev tk8.6-dev python-tk

Ubuntu 18.04

Sudo apt install libjpeg8-dev zlib1g-dev

Fedora 20

Das Fedora 20-Äquivalent von libjpeg8-dev ist libjpeg-devel.

Sudo yum install libtiff-devel libjpeg-devel libzip-devel freetype-devel lcms2-devel libwebp-devel tcl-devel tk-devel

Mac OS X (über Homebrew)

Unter Mac OS X mit Homebrew kann dies folgendermaßen behoben werden:

brew install libjpeg zlib

Möglicherweise müssen Sie zlib auch mit den folgenden Methoden zwangsweise verknüpfen:

brew link zlib --force

Update April 2019: In Mojave funktioniert das oben genannte nicht und Sie müssen das folgende ausführen, wie aus diesem Fehlerbericht hervorgeht Kissen

Sudo installer -pkg /Library/Developer/CommandLineTools/Packages/macOS_SDK_headers_for_macOS_10.14.pkg -target /

Update Juli 2016: Es ist keine Formel für zlib mehr im Haupt-Repository verfügbar (Homebrew fordert Sie auf, lzlib, eine andere Bibliothek, die dieses Problem nicht löst).

Es gibt is eine Formel im dupes Repository. Sie können entweder auf dieses Repository tippen und es wie gewohnt installieren:

brew tap homebrew/dupes
brew install zlib

Oder Sie können zlib stattdessen wie folgt über xcode installieren:

xcode-select --install

Dank an Phoenix, Panos Angelopoulou, Nelsonvarela, Benjaminz und Kal in den Kommentaren

Nachdem diese installiert wurden, sollte die Rohrinstallation von Pillow normal funktionieren.

300
mfitzp

Auf Raspberry Pi II hatte ich das gleiche Problem. Nachdem ich Folgendes versucht hatte, löste ich das Problem. Die Lösung ist:

Sudo apt-get update
Sudo apt-get install libjpeg-dev
36
xjfengck

Die schnellste Lösung ist das Upgrade des Pip. Hat für mich gearbeitet:

pip install --upgrade pip
12
Aman Yadav

Das hat bei mir funktioniert.

   `Sudo apt-get install libjpeg-dev`
12
Thomas John
brew install zlib

unter OS X funktioniert nicht mehr und fordert stattdessen zur Installation von lzlib auf. Das zu installieren hilft nicht.

Stattdessen installieren Sie XCode Command Line Tools und das sollte zlib installieren

xcode-select --install
10
Kal

Ich hatte die ValueError: zlib is required unless explicitly disabled using --disable-zlib aber ein upgrade von pip von 7.x auf 8.y hat das problem behoben.

Also würde ich versuchen, die Tools vor allem anderen zu aktualisieren.

Das kann gemacht werden mit:

pip install --upgrade pip
6
Brambor

Dies funktionierte für mich, um JPEG- und ZLIB-Fehler zu lösen:

C:\Windows\system32>pip3 install pillow --global-option="build_e
xt" --global-option="--disable-zlib" --global-option="--disable-jpeg"
6
B-shan

Die Alternative, wenn Sie libjpeg nicht installieren möchten:

CFLAGS="--disable-jpeg" pip install pillow

From https://pillow.readthedocs.io/de/3.0.0/installation.html#external-libraries

2
shangxiao

Versuchen

pip install pillow

Wenn es nicht funktioniert, löschen Sie die

cache by pip install --upgrade pip

Dann nochmal rennen

pip install pillow