it-swarm.com.de

Fehler bei der Installation mit pip

Nicht sicher, was hier vor sich geht, aber ich bekomme jedes Mal eine Fehlermeldung, wenn ich versuche, etwas mit Pip zu installieren. Ich erhalte die folgende Fehlermeldung:

Befehl "/ usr/bin/python -c" import setuptools, tokenize; __ file __ = '/ private/var/folders/b0/5843zgyj1yz3b8q2l7wrtj8h0000gn/T/pip-build-V4hy8S/PySocks/setup.py'; exec (compile (get) (tokenize, 'open', open) (__Datei__). read (). replace ('\ r\n', '\ n'), __Datei__, 'exec')) "install --record/var/folders/b0 /5843zgyj1yz3b8q2l7wrtj8h0000gn/T/pip-bIOl7C-record/install-record.txt --single-version-extern verwalteten --compile“mit dem Fehlercode 1 in/privaten fehlgeschlagen/var/Ordner/b0/5843zgyj1yz3b8q2l7wrtj8h0000gn/T/Kern- build-V4hy8S/PySocks

13
lcm

Scheint, dass Ihr PiP nicht auf Setuptools zugreifen kann. Versuchen Sie es zuerst mit den folgenden Anweisungen, und führen Sie dann die Pip-Installation erneut aus. 

Sudo pip install -U setuptools

Lösung von Github Ausgabe

11
Dusty Boshoff

Versuchen

Sudo pip install -U setuptools

Wenn dies Ihr Problem nicht löst, dann

Erstens benötigen Sie das python-dev-Paket, da Pillow definierte Kompilierkopfzeilen benötigt.

Sudo apt-get install python-dev

Auf Ubuntu 14.04 benötigen Sie ein paar zusätzliche Pakete, um Kissen zu bekommen. Installieren Sie alle mit dem Befehl:

Sudo apt-get install libtiff5-dev libjpeg8-dev zlib1g-dev libfreetype6-dev liblcms2-dev libwebp-dev tcl8.6-dev tk8.6-dev python-tk

12
Astik Anand

Starten Sie den Befehl Eingabeaufforderung mit "Als Administrator ausführen", bevor Sie . Installieren.

pip install package_name_here

wenn ein Fehler ausgegeben wird, importieren Sie Setup-Tools

pip install -U setuptools

wenn erneut ein Fehler ausgegeben wird, aktualisieren Sie Ihr Pip-Installationsprogramm mit diesem Skript (persönlich für mich gearbeitet)

python -m pip install --upgrade pip
3
CodeManga

Ich hatte das gleiche Problem unter Windows Git Bash, aber das Installieren von Setuptools hat es nicht behoben. Dann bemerkte ich eine weitere Fehlermeldung weiter oben: 

building 'twisted.test.raiser' extension error: Microsoft Visual C++ 14.0 is 
required. Get it with "Microsoft Visual C++ Build Tools": 
http://landinghub.visualstudio.com/visual-cpp-build-tools

Dieser Link war tot, aber letztendlich hatte diese Seite einen Link zum korrekten Download: https://wiki.python.org/moin/WindowsCompilers

Ich habe Microsoft Build Tools für Visual Studio 2017 installiert und das wurde behoben.

1
leastgrebe

zuerst als Superuser laufen:

Sudo su

dann :

pip install PyOpenGL PyOpenGL_accelerate
1
Ahmed Mohamed

Dies hängt hauptsächlich von der Art der Pakete ab, die Sie installieren möchten. Häufig schlägt es fehl, weil libsasl2-dev ein package für Authentifizierungs-Abstraktionsbibliothek fehlt, die in der Ubuntu-Version verwendet werden

Installieren Sie zuerst:

Sudo apt-get install libsasl2-dev

dann renne:

pip install <<\package_name >>

0
Skanda Shastry

Wenn Sie diesen Fehler wie unter Windows erhalten, führen Sie einfach das Befehlszeilenprogramm (cmd.exe oder Powershell) als Administrator aus, und versuchen Sie es erneut.

0
Hans Goldman