it-swarm.com.de

Eclipse, PyDev "Projektinterpreter nicht angegeben"

Ich habe PyDev in Eclipse Luna installiert. Nach der erfolgreichen Installation von PyDev, wenn ich ein neues Projekt erstellen möchte, erhalte ich die Fehlermeldung: Projektinterpreter nicht angegeben

Wie kann ich es reparieren? Es gibt keine Auswahlmöglichkeit für den Interpreter. 

Eclipse-Version Luna, Mac OSX Yosemite, PyDev neueste Version (installiert gemäß http://pydev.org/manual_101_install.html )

enter image description here

12
apadana

In meinem Fall hat es mit folgenden Schritten gearbeitet

Voraussetzung: Python sollte installiert sein

  1. Gehen Sie zu Window -> Preferences -> PyDev -> Interpreters und klicken Sie auf "Python Interpreter".
  2. Klicken Sie dann auf die Schaltfläche "Neu" und fügen Sie den ausführbaren Python-Speicherort hinzu.

Beispiel für Windows:

c:\python2.7\python.exe

beispiel für Ubuntu:

/usr/bin/python
  1. Dann können Sie ein Bild anhängen und auf Fertig stellen klicken.

Es sollte funktionieren.

34

Auf meinem Mac 10.11.3 habe ich es mit LiClipse 2.5.3 mit folgenden Schritten gelöst:

Öffnen Sie ein Terminalfenster und geben Sie which python ein.

In meinem Fall antwortete es mit /usr/bin/python

Beim Aufruf von Python wurde mir mitgeteilt, dass ich Version 2.7.10 verwende.

Als Nächstes rief ich LiClipse an und ging zu LiClipse -> Einstellungen -> PyDev -> Interpreter -> Python-Interpreter -> Neu

Für "Interpreter-Name" habe ich "Python 2.7.10" verwendet, obwohl mir bekannt ist, dass es sich nur um einen Sym-Link handelt, der jederzeit aktualisiert werden kann. Für "Interpreter Executable" habe ich "/ usr/bin/python" eingegeben

Dann OK"

Danach ging die Fehlermeldung weg.

 setting python interpreter location

2

In meinem Windows-System ist der ausführbare Python-Pfad C:\tools\python2\python.exe.

gehen Sie zu Eclipse Window -> Preferences -> PyDev -> Interpreters, klicken Sie auf "Python Interpreter" und zeigen Sie auf den ausführbaren Python-Pfad.

0
Selvaji