it-swarm.com.de

Django 2.0 kann nicht über Pip installiert werden

Ich baue eine neue Django-App mit einer neuen Version von Django ..__ Ich fand Django 2.0 ist verfügbar (2.0.2) https://www.djangoproject.com/download/ und versucht nun, es zu installieren mit pip.

pip install Django == 2.0.2

Aber es funktioniert nicht für mich.

Konnte keine Version finden, die die Anforderung Django == 2.0 .__ erfüllt. (von Versionen: 1.1.3, 1.1.4, 1.2, 1.2.1, 1.2.2, 1.2.3, 1.2.4, 1.2.5, ... 1.2.6, 1.2.7, 1.3, 1.3.1 1.3.2, 1.3.3, 1.3.4, 1.3.5, 1.3.6, 1.3.7, 1.4, 1.4.1, 1.4.2, 1.4.3, 1.4.4, 1.4.5, 1.4.6 1.4.7, 1.4.8, 1.4.9, 1.4.10, 1.4.11, 1.4.12, 1.4.13, 1.4.14, 1.4.15, 1.4.16, 1.4.17, 1.4.17, 1.4.18, 1.4 .19, 1.4.20, 1.4.21, 1.4.22, 1.5, 1.5.1, 1.5.2, 1.5.3, 1.5.4, 1.5.5, 1.5.6, 1.5.7, 1.5.8, 1.5 .9, 1.5.10, 1.5.11, 1.5.12, 1.6, 1.6.1, 1.6.2, 1.6.3, 1.6.4, 1.6.5, 1.6.6, 1.6.7, 1.6.8, 1.6 .9, 1.6.10, 1.6.11, 1.7, 1.7.1, 1.7.2, 1.7.3, 1.7.4, 1.7.5, 1.7.6, 1.7.7, 1.7.8, 1.7.9, 1.7 .10, 1.7.11, 1.8a1, 1.8b1, 1.8b2, 1.8rc1, 1.8, 1.8.1, 1.8.2, 1.8.3, 1.8.4, 1.8.5, 1.8.6, 1.8.7, 1.8 .8, 1.8.9, 1.8.10, 1.8.11, 1.8.12, 1.8.13, 1.8.14, 1.8.15, 1.8.16, 1.8.17, 1.8.18, 1.9a1, 1.9b1, 1.9 rc1, 1.9rc2, 1.9, 1.9.1, 1.9.2, 1.9.3, 1.9.4, 1.9.5, 1.9.6, 1.9.7, 1.9.8, 1.9.9, 1.9.10, 1.9.11 1,9.12, 1.9.13, 1.10a1, 1.10b1, 1.10rc1, 1.10, 1.10.1, 1.10.2, 1.10.3, 1.10.4, 1.10.5, 1.10.6, 1.10.7, 1.10. 8, 1.11a1, 1.11b1, 1.11rc1, 1.11 1.11.1, 1.11.2, 1.11.3, 1.11.4, 1.11.5, 1.11.6, 1.11.7, 1.11.8, 1.11.9, 1.11.10) Keine übereinstimmende Verteilung für Django == 2,0 gefunden

Ich benutze Python 2.7.14 und Pip 9.0.1. Was ist hier los?

28
Snipper03

Django 2.x wird nicht mit Python 2.x unterstützt.

Von der Django Download-Seite :

Wir empfehlen die Verwendung der neuesten Version von Python 3. Die letzte Version von Unterstützung Python 2.7 ist Django 1.11 LTS.

Sie sollten Python 3.x mit Pip3 verwenden:

pip3 install Django
52
Peter Sobhi

wenn Python3 installiert ist, versuchen Sie es 

pip3 install Django==2.0.2
8

Für Django 2.1.2 passiert mir dieselbe Einstellung. Ich habe dieses hier unten ausprobiert und es funktioniert gut für mich.

pip3 install Django==2.1.2
0
Musa Toktaş

Django 2.0 unterstützt nur Python 3.x

0
uristlikot

Aus den Versionshinweisen

Kompatibilität mit Python Django 2.0 unterstützt Python 3.4, 3.5 und 3.6. Wir Ich kann die neueste Version von .__ nur wärmstens empfehlen und nur offiziell unterstützen. jede Serie. Die Django 1.11.x-Serie ist die letzte, die Python unterstützt 2,7. Django 2.0 wird die letzte Release-Serie sein, die Python 3.4 unterstützt. Wenn Sie eine Bereitstellung von Python 3.4 für .__ nach dem Ende des Lebenszyklus planen. Django 2.0 (April 2019), stattdessen Django 1.11 LTS (unterstützt bis zum __. April 2020). Beachten Sie jedoch, dass das Lebensende für Python 3,4 ist März 2019.

0
dfundako